Linux Tentacle running as non-root user

Is it possible to run Linux Tentacle as different user than root?
I’ve changed user in service settings (/etc/systemd/system/Tentacle.service) but I guess it’s not enough because Tencle doesn’t have permissions to basic files. Exception from Powershell Core:
System.UnauthorizedAccessException: Access to the path ‘/etc/octopus/Tentacle/Work/20200302122305-121668-1’ is denied

“Where would you like Tentacle to store log files? (/etc/octopus)”
I will try to pass different path during Tentacle setup, f.ex. /home/Octopus

Hi @rafal.gapski!

You’re correct that you can run the Tentacle service as a different user by modifying the service file. You’re also on-the-money about your filesystem permissions, if you do change this user, you will need to ensure that your new server has access to all of the locations configured when you configured the tentacle.

I hope this helps, please don’t hesitate to reach out if you have any further questions.


I am trying to start Tentacle on a linux box where I have no root access, I have no access to /etc.
When I run Tentacle create-instance --instance "Tentacle" --home /home/octopus it complains about access denied to /etc/octopus/Tentacle/Instances

Is it possible to override /etc/octopus ?

I tried to bring config with certificate from another machine where I have root access, but it still does not want to start because I guess /etc/octopus/machinekey is missing

Sadly, no. The tentacle client uses /etc/octopus as its config location.

What some users have done is symlink /etc/octopus to another directory so that the various tentacle changes can be performed while not giving full access to /etc/, but it would require someone with root/sudo access to perform the initial symlink creation.