Let’s Encrypt renewal never finishing forever

Running Octopus Server v2021.3 (Build 8275) in a VM. The task ‘Configure Let’s Encrypt SSL Certificate’ never finishes and causes Octopus server to stop automatic deployments, because they never start, because this task never finishes and there’s no timeout. This task has been working fine for years. For the past month, it never gets past ‘Waiting for other tasks to complete’. It will wait forever (days, at least), until someone comes in and cancels the task. It will eventually try again and fail to complete.

I’ve tried disabling and re-enabling Let’s Encrypt. Same result.

I found Let's Encrypt renewal never finishing - #7 by paul.calvert, but there doesn’t appear to be a real solution. I also tried to enter maintenance mode and cancel the task. It doesn’t help, this task continues to get stuck.

Hi @SamRueby,

Thanks for reaching out and I’m sorry to see you’re running into problems with your Let’s Encrypt task.

Looks like you’re running into this bug on your version. Would it be possible to apply the workaround described in the issue until 2021.3.8815 (or later) becomes public?

Looking forward to hearing back.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.