Latest Teamcity (2018.1.3 (build 58658)) nuget feed not working anymore


(Wolfgang Malgadey) #1

Before I upgraded our teamcity installation to build 58658, I was able to get all available nuget packages from our teamcity.

After the upgrade, I see two different outputs:

  1. in test, I only see some of my packages
  2. while creating releases I see only major releases no pre-releases and no new releases

When I use the same feed for example in visual studio, everything works fine. I see all available releases.

This worked before the upgrade. I updated octopus to latest version yesterday!


(Henrik Andersson) #2

Hi Wolfgang,

Thanks for getting in touch and I’m sorry to hear that you’re having these issues.

Could you tell me what version of TeamCity you upgraded from? In 2018.1 TeamCity made a change to the feed to be per-project instead of global and the paths changed and this could be why you are having these issues.

Thank you and best regards,
Henrik


(Wolfgang Malgadey) #3

This is an old issue. There is still a root repository in 2018.1.3 (Build 58658) and in visual studio I can see all available packages.


(Henrik Andersson) #4

Hi Wolfgang,

My apologies for the delay in getting back to you.

This issue is a bit strange as I have been unable to replicate the issue with a local instance of Octopus and TeamCity running 2018.1.3.

Could you send through a screenshot of the available package sources in Visual Studio and also the external feed in Octopus?

Thank you and best regards,
Henrik


(system) #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.