Kubernetes deploy with “Registry Path” property issue

(Edward Grave) #1

We are using JFrog’s Artefactory as our Docker image repository and that requires us to set it up as an External Feed in Octopus with the “Registry Path” property set to “repo.imageregistry.com/docker”. This is because the URL is not the same as the URL provided for the location of the feed.

This is working fine when we deploy Docker images from this repo directly to a standalone Docker host.

The image name is sent as: repo.imageregistry.com/docker/imagepath/myimage:tag

The issue we are seeing is when deploying to a Kubernetes cluster the image is sent as: repo.imageregistry.com/imagepath/myimage:tag

Notice the “docker“ path is missing. The deployment is not using the “Registry Path” property from the external feed.

We’ve yet to find a way to get this to work. Is it a bug or is it a miss-configuration on our side?

(Michael Richardson) #5

Hi Edward,

We sincerely apologize for the delayed response on this one.

We believe this was a bug that may have been resolved in Octopus 2019.1.8.
If you are on an earlier version, upgrading should hopefully see it work. If you are on 2019.1.8 or later, please let us know and we will investigate further.

(Edward Grave) #6

Hey,

No problem, you are correct. We have upgraded to the latest version 2019.1.8 and the issue has resolved.

Thanks for your response.