InstallUtil appears to put parameters in the wrong place

I’ve modified my service to take some command line parameters, and verified that the modifications work when directly running InstallUtil.

However, when installing via Octopus the parameters aren’t available to my installer and the install fails. On investigation I’ve found that it matters what order you write the parameters on the command line:

Octopus runs:
InstallUtil /i “PATHTOMYASSEMBLY” /myparameter=“myparamvalue”

If I run the same command manually, it doesn’t work as the parameters aren’t pass through to my installer class. However, the following command DOES work:

InstallUtil /i /myparameter=“myparamvalue” “PATHTOMYASSEMBLY”

ie it seems you have to put the assembly last to make the parameters available.

I’ve not seen any documentation on this of MSDN but I can confirm it definitely happens on both my machine and on the dev VM I’m playing with Octopus on (Windows Server 2003 atm).

Hi Niel,

Thanks for this, I’ll check it out and get you a new build in 5 hours.

Sent from my Windows Phone

Wow, thanks very much :slight_smile:

Hi Niel,

Thanks again, I have fixed this bug and it is available in the latest build here:

Hope that helps,


Thanks for the quick new build!

Finally got around to trying this, but it doesn’t seem to have helped, the assembly name is still before the parameters:

2011-09-29 16:53:02 DEBUG Running InstallUtil /i “C:\Octopus\Tentacle\Applications\TestService\TestService.exe” /myparameter=“myvalue”

In the same output file:
2011-09-29 16:52:09 DEBUG - Tentacle Version:

I uninstalled the old Tentacle and installed the new one first, but for the Octopus I just ran the installer without uninstalling. Is there anything else I’d need to do to get the new behaviour?

Hi Neil,

The code has definitely been changed and was in the latest build. Can you try re-installing the Tentacle again?

  1. Stop the Octopus Tentacle service if it is running
  2. Uninstall it
  3. Install the new Tentacle build

A few people seem to get problems installing new versions of Tentacle - something I hope to solve very soon due to automatic updates.


It worked! You’re right about the installing the new version being painful - I had to do it twice because the first time I left the service running and it didn’t actually update it. The second time I thought it had failed again as when I pressed ‘Update’ on the config window it claimed it was already installed, but it had actually updated it. So it worked but was slightly confusing.

Thanks :slight_smile:

Thanks for the update Neil. I’m working on an automatic update feature for Tentacles that should mean manual installs are a thing of the past :slight_smile:

Sent from my Windows Phone