IIS deployment problems

I have configured two steps, 1. Deploy package, 2. Deploy to IIS.
During IIS deployment stage it fails as unable to find “C:\MVCAdminTemplate” Path. The first step already deployed the package in "“C:\Octopus\Applications\UAT\MvcAdminTemplate.Release”. How i configure the step to find the deployment in correct location.

I attach my deployment failure log file, and IIS screenshot


Thanks for reaching out! In Octopus 3.4.7 we introduced a “Deploy an IIS Website” step that takes care of both the package deployment and the IIS setup (see documentation

Are you using this step? If that is the case, then you shouldn’t need the first step to deploy the package. If that is not the case, we strongly recommend you to upgrade to at least that version to be able to use this new step.


Thanks Dalmiro, It works. In “C:\Octopus\Applications\UAT\MvcAdminTemplate.Release” path, it has lot of folder ids with version number(1.0.0_35, 1.0.0_34, 1.0.0_33).

In iis setup step, currently the physical path = “C:\Octopus\Applications\UAT\MvcAdminTemplate.Release”. I want to include the last successful release number(1.0.0_35, 1.0.0_34, 1.0.0_33) in the path, which parameter i should use.

If you leave the Physical Path field empty, It’ll be default point your app to the path of the current release. So if you are deploying 2.0.0, It’ll point it to C:\Octopus\Applications\UAT\MvcAdminTemplate.Release\2.0.0

Let me know if that works

Thanks it works