Git repository URLs with spaces are rejected

Hi,
I’m trying to set up version control with a project whose Git repository URL has a space in it.
For example, using https://dev.azure.com/resnikb/_git/Octopus%20Demo works in browser, but fails in Octopus. Similarly, https://dev.azure.com/resnikb/_git/Octopus Demo also works in browser but fails in Octopus.

The error message from Octopus is:

We were unable to connect to your remote repository (). Please check the URL, default branch name and authentication details.

We are using Octopus version 2022.3.10863.

Any help is appreciated.
Kind regards,
Bojan

Hi @resnikb,

Thanks for getting in touch! I’m sorry to hear about this trouble setting up version control. I’ve actually seen this error thrown in the past which ended up being an authentication issue. Are you able to confirm whether or not that’s a possibility here?

From there, would you be willing to share a screenshot showing your project’s version control settings (redacting any sensitive details)? That should give us a good starting point to troubleshoot this issue. If you’re more comfortable sharing that via email, feel free to send it to support@octopus.com and we can pick it up from there.

I look forward to hearing back and narrowing down what might going on here.

Best regards,

Kenny

Hi Kenny,
Thanks for the quick response, and for the pointer - authentication was indeed the issue.
I’ve fixed that, and it all works now.

Thank you very much!
Bojan

Hey Bojan,

Anytime! Awesome to hear you’ve found and fixed the issue. I appreciate the confirmation. If you have any questions or concerns in the future, don’t hesitate to shout out. :slight_smile:

Best regards,

Kenny