FTP broken in 2.4.7 (5 out of 5 transfers failed)

I was using version 2.3.3 and FTP sort of worked against the Azure websites. There were some publishing issues so I decided to upgrade. After the upgrade I keep getting these errors.


Info 15:55:05
Connected; beginning synchronization…

Info 15:55:21
Synchronize complete

Info 15:55:21
Total operations: 5

Fatal 15:55:22
5 out of 5 transfers failed
EnterpriseDT.Net.Ftp.FTPSyncException: 5 out of 5 transfers failed
at EnterpriseDT.Net.Ftp.FTPTask.r4M6UXrqub()
at YCI9u27a1oMu68GXnaS.OFnVm47SuspJNvpIdPM.uoCtiI730uhppJYuAkP.get_ReturnValue()
at YCI9u27a1oMu68GXnaS.OFnVm47SuspJNvpIdPM.LIVb42QLjtN(IAsyncResult )
at YCI9u27a1oMu68GXnaS.OFnVm47SuspJNvpIdPM.r1rb4k9V5sa(FTPSyncRules , String , String )
at EnterpriseDT.Net.Ftp.ExFTPConnection.Synchronize(String localDirectory, String serverDirectory, FTPSyncRules syncRules)
at Octopus.Tentacle.Integration.Ftp.FtpSynchronizer.SynchronizationSession.Execute() in y:\work\refs\heads\master\source\Octopus.Tentacle\Integration\Ftp\FtpSynchronizer.cs:line 89
at Octopus.Tentacle.Integration.Ftp.FtpSynchronizer.Synchronize(FtpSynchronizationSettings settings) in y:\work\refs\heads\master\source\Octopus.Tentacle\Integration\Ftp\FtpSynchronizer.cs:line 16
at Octopus.Tentacle.Procedures.Implementations.Ftp.FtpUploadProcedure.Upload(ProcedureState state, CancellationToken cancel) in y:\work\refs\heads\master\source\Octopus.Tentacle\Procedures\Implementations\Ftp\FtpUploadProcedure.cs:line 69
at Pipefish.Async.CaptiveThread1.ThreadAction(Action2 action, Guid operationId, IActivitySpace space, Guid captiveThreadId) in c:\TeamCity\buildAgent\work\cf0b1f41263b24b9\source\Pipefish\Async\CaptiveThread.cs:line 114

What does this mean? How can I fix this?

I’m deploying via FTP using of Octopus Deploy from a VM running in the Azure datacenter. My tentacle is up to date. I’ve tried what I believe to be all combination of PASSIVE/ACTIVE, FTPS/FTP and ftp and ftps URLs. Realize I wasn’t getting this problem until I upgraded to the 2.4.7 version of Octopus Deploy.

Hi Paul,

Thanks for getting in touch! We didn’t change anything related to FTP between 2.3.3 and now, but we’ve seen similar issues reported. The problem seems to be with Azure occasionally dropping connections and our FTP client not automatically reconnecting/trying again. We’ve followed it up with the vendor but reproducing it and finding the cause is very tricky.


We do have a new step template in our library that you can use to use WebDeploy instead of FTP, which seems to be much more reliable. Would you be able to try switching to this?