Found Unmapped Ids - Project variables

We are trying to import projects from default space to a new space but when we try to import the exported the project in the new space, this error is shown. Based on this research, it seems that we have to delete the release ‘1.0.0’. We want to maintain our environments as much as possible so is there another way to work around this issue? Also, I thought the environments are imported together so I am confused why such thing happens. Appreciate much help.

Found unmapped Ids in document 'Variables ’ (Octopus.Core.Model.Variables.ProjectVariables): “Id”: “Environment name”, “Id”: “<Environment name”, “Id”: ",. Reference path: Project ‘FastScanAPI’ => Release ‘1.0.0’

I found a similar issue and I see that the problem is solved in Octopus Release.

If anyone could help how it was resolved and how I can fix it, it is much appreciated.

Note** Replaced “Id” values with “Environment name” for security purposes.

Hi @eimyatnoeaung98
Thanks for contacting our Support forum.

Sorry to hear you’ve run into this issue. As you pointed out there is a fix once you upgrade.

Looking at your GH screenshot, it relates to one of two similar issues with Unmapped IDs:

Your screenshot relates to 7197 and no workaround is shown in this one. On the similar 7391 it relates more to runbooks - can you clarify if it was more related to JIRA work items or to runbooks?

If the latter we do have a PS script to help with the migration. The script cleans up any snapshotted variables scoped to deleted runbooks, outputting a modified zip file. You should be able to import this modified zip file successfully into an Octopus instance.
However this may not work for your scenario or you may have to modify the script to work for you.

Can you try upgrading and see if the export avoids this error?

Kind regards,

Hello Pariac,

Thank you for reaching out. my error is related to environments and the release. In case, the release was causing the problem, I deleted the release causing the error and exported and imported again. But it’s still saying the same error.

Hi @eimyatnoeaung98

One thing that could be causing the issue would be a release linked to the project.
If you do not require the release information, you can clone the project in the same space.
Then once that’s cloned you can then export the clone project and then import the project into the new space.

Please give that a try and see if that resolves the issue.

Kind Regards,

I tried what you recommend and it worked. But we would like to import the releases in the new space. Would there be another solution?

I tried deleting the release that was causing the error. It still did not work. Now the error is pointing to the next release in the list. I think the error lies in the environments but I do not know why environments are causing the issue. If there is a way to solve this issue, I would highly appreciate it.

Hi @eimyatnoeaung98,
Unfortunately it looks like we don’t have a direct fix for the environments issue. If you would like us to dig a bit deeper would you be able to send us your recent Server logs:

Also we can take a look at your export and perhaps one of our engineers might take some time to go through it and see if we can fix it up for you and maybe preserve the releases and environments. You can upload the logs and the export zip file to this secure location:

I can’t promise we can completely fix the issue but we can certainly take a look.

In the meantime upgrading would be a good option - notes on this attached:

In-place upgrades to our latest version are supported for all versions of Octopus later than 3.0. If you are upgrading several major versions in one go (e.g. 3.0 to 2020.6) we would recommend creating a test instance and performing the upgrade there first to ensure no unexpected problems arise.

I would recommend reviewing the changes between these versions, especially any breaking changes, in our version comparison tool: Compare releases - Octopus Deploy

Also, you can find our full upgrade guide here: Upgrading major releases of Octopus Deploy | Documentation and Support

Kind regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.