Failing to expose Octopus server over https

operations

#1

Hei,
we are just starting to use Octopus deploy and I’m trying to set up the Automated deployment through VSTS.
I’ve checked all the documentation and related threads but still am unable to find an answer of why the public link to the octopus server isn’t working. I keep getting: This page cannot be displayed.

I’ve set the new https binding with an existing certificate through Octopus Manager Wizard and in Nodes in the server configuration. Localhost is working fine (no forcing to https yet)
I used the default port 443.

Is there something I’m missing?


(Lawrence Wilson) #3

Hello,
Thanks for getting in touch! I’m sorry to hear you are seeing issues setting up Octopus to work over HTTPS.

My understanding is that the default setup works fine, while connecting to http://localhost:80/app and that your browser is currently failing to connect to https://localhost:443/app

Are you only seeing these issues while connecting to your Octopus Server from a different server? or are you unable to get to the Octopus Portal from a web browser directly on your Octopus server as well?

If possible, could you please let me know what the existing bindings are set to in your Octopus Server Manager?

One possibility could be that the Octopus Server service is stopping. In this case we can check if the octopus service is started in the services console.

In your tests are you using the self-signed certificate option?

I look forward to hearing from you.

Kind Regards,
Lawrence.


#4

Hei, Lawrence!

Thank you for reply. We solved the issue by updating the SSL certificate (it was outdated). After that all other machines started to see the server as well.