Exception when acquiring the package

Today i tried to deploy a new version to our linux server. It worked fine the last time, but this time i got an error during deployment. When the package is being acquired the following error is thrown:

The step failed: Activity failed with error 'Could not load file or assembly ‘System.Security.Cryptography.Algorithms, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’. The located assembly’s manifest definition does not match the assembly reference. (0x80131040)

I have already updated the octopus deploy server to the latest version.
The only thing i changed, was that i installed dotnet 7 on the server.

Does anyone has an idea whats going on here?
Thanks in advance,

Good afternoon @michael.prattinger,

Thank you for contacting Octopus Support and welcome to the forums!

I am sorry you are seeing an issue with one of your deployments, we have seen similar error messages before and it is possible that deleting the calamari files in the tools folder on your tentacle will resolve this issue as it will force your machine to grab a new calamari version, we think the tentacle may be picking up an old dll so need to rule that out.

I can see your tentacle is on a Linux OS so I am not quite sure where your tools folder in your tentacle would be located but by default it will be located here:

/etc/octopus/<Instance Name>/Tools

If you go into that and delete the Calamari.linux-x64 file and any other files in there and then try and redeploy that package to the Linux tentacle it should re-download a new calamari version and we can see if that fixes that error, if not are we able to get the full logs of the Linux tentacle please

(found in /etc/octopus/<Instance Name>/Logs)

and we can see if we can spot anything out of the ordinary. I have created you a secure link here if you need to send those logs through, let me know once you have sent them and I can take a look and ensure we got them.

I look forward to hearing from you,
Kind Regards,

Hi Clare,

thanks for your response.
After i followed your suggested steps and restarted the systemd service everything works.

Thank you very much
r Michael

Hey @michael.prattinger,

Great news that fixed the issue, thank you for letting me know, reach out in future if you need anything further as we are always on hand to help!

Kind Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.