Error While Uploading to S3 Bucket


(Elliot Parsons) #1

I am attempting to upload a complete build artifact to S3, but I get the following error.

I have verified that the AWS user has access to the bucket.

My Octopus Server version is 2018.4.11 and it is using Calamari.Aws 4.5.8.

NOTE: I have also performed this on my development server running 2018.9.15 and received the same error.


(Shaun Marx) #2

Hi Elliot, thanks for getting in touch,

The error does seem to suggest that the account being used does not have the correct permissions. Could I just confirm whether the account has the following permissions for the associated bucket?

  • GetObject
  • PutObject
  • PutObjectTagging

Do you have any other projects currently uploading to S3 that manages to succeed uploading? Although unlikely, a proxy and or firewall may also be interfering if this is failing for everything.

Could you also attach the raw task logs from the deployment so that we can have a closer look, please?

Regards,
Shaun


(Elliot Parsons) #3

Shaun -

I temporarily gave the account global admin permissions and still received the error. I tried this on the 2018.9.15 instance and it worked, so I think it was a combination of the version and incorrect permissions.

Thank you