Error Stopping IIS App Pool

support

(Brad J) #1

We recently upgraded to v2018.4.10. We also upgraded all tentacles during this process. When deploying to one of our servers, we are receiving the following error:

stop-webitem : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
Error
At C:\Octopus\Applications\Production -
Error
Blue\GreenPath.ClientPortal.WebAPI\1.0.18253+01_3\Octopus.Action.CustomScripts.PreDeploy.ps1:6 char:5
Error

  • Stop-WebAppPool -Name $appPoolName 
    

Error

  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 
    

Error
+ CategoryInfo : InvalidData: (IIS:\apppools\ClientPortalv2Api:String) [Stop-WebItem], UnauthorizedAccess
Error
Exception
Error
+ FullyQualifiedErrorId : InvalidOperation,Microsoft.IIs.PowerShell.Provider.StopItemCommand

This is using the standard IIS deploy step. The user the tentacle is running under has full admin privileges to the machine. This user is running as the tentacle on other machines in our environment and we have been able to deploy without issue. We have also tried re-installing the tentacle.

Is there anything else we can try? Thanks in advance for any help you can provide.


(Brad J) #2

After more digging, this was an IIS configuration issue on the server that was made by someone else.


(Daniel Fischer) #4

HI Brad,

Thanks for getting in touch! I’m glad to hear that you resolved your issue. :slight_smile:

Please feel free to get in touch at any time.

Best regards,
Daniel


(Rajesh Gandhi) #5

@bcjohnson, Hi Brad - m also getting the same error. may i know what change you have done in IIS?


(Daniel Fischer) #6

Hi @RajeshGandhi,

Thanks for getting in touch here. If you are still stuck here, you will need to attach the full raw deployment log file.

If the logs contain sensitive information, you may want to create a new conversation for this and have us make it private before you attach the logs.

Looking forward to hearing from you.

Best regards,
Daniel