Error on upgrade from version 3.13.8 to version 2018.3.5


I have just run an Octopus upgrade.

I went from Octopus Version 3.13.8
to Octopus version 2018.3.5

The upgrade ran without error but I cannot login to Octopus due to authentication errors.

I am now getting the following errors in the Octopus log.

2018-03-20 19:46:33.1934 1304 84 ERROR Unhandled error on request: 9d88b9c84ecf4f6abab8b03163edcd6b by : authentication configuration initialization has not executed
System.InvalidOperationException: authentication configuration initialization has not executed
at Octopus.Node.Extensibility.Extensions.Infrastructure.Configuration.ConfigurationDocumentStore1.GetProperty[TProperty](Func2 prop)
at Octopus.Server.Web.Api.Actions.Authentication.AuthenticationResponder.ExecuteRegistered()
at Octopus.Server.Web.Infrastructure.Api.Responder`1.Respond(TDescriptor options, NancyContext context)
at System.Dynamic.UpdateDelegates.UpdateAndExecute3[T0,T1,T2,TRet](CallSite site, T0 arg0, T1 arg1, T2 arg2)
at Octopus.Server.Web.Infrastructure.OctopusNancyModule.<>c__DisplayClass14_0.<get_Routes>b__1(Object x)
at Nancy.Routing.Route.<>c__DisplayClass4.b__3(Object parameters, CancellationToken context)

I also cannot login.
The browser just says “authentication configuration initialization has not executed”

Which matches the log.

I will be very greatful for any advice.


I just performed an upgrade to to the same version from about the same version (3.14.5, I think) and am running into the exact same error. Sorry to say I don’t have a solution yet, either, but I will keep you posted.

I’m in the same boat right now too. Hoping there is a fix for this issue.

Just created an account to post the same issue, but it seems others are already affected by it. Bad times :frowning:


Thanks for reaching out and sincere apologies for this inconvenience. We have been able to confirm what’s causing the issue and have a fix in the pipeline as I type.

The issue caused Octopus to not recognise that some configuration data needed migrating. So the error your’e seeing relates to it seeing the old shaped data in the database. The fix will has corrected the check and the migration will now run, so if you haven’t rolled back you should be able to install 2018.3.6 when it ships and move forward without any issue.

As I mentioned, the fix is in the pipeline and we expect to have it shipped within an hour or 2.

Again, sincere apologies for the inconvenience caused.



Thank you for the quick response.

Get Outlook for iOS

This resolved my issue, Shannon, thank you! I was able to downgrade to the previous version with no complications.

Thanks so much!

Installing version 2018.3.6 fixed the issue.
Everything appears to be working happily now.

Thanks for the quick response.

All solved for me too with 2018.3.6! Thanks for the fast resolution :slight_smile:

Had the same here going from 3.17.13 but resolved with the new patch
Many thanks for the quick resolution

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.