Deployment tracking by integrating Octopus Deploy and Raygun does not work

We have been using deployment tracking for a long time, integrating Octopus Deploy and Raygun.

This works for us all the time. But from July 4, 2022, it does not work.
We catch this error when we try to call raygun api form Octopus Deploy: “The main connection was closed: An unexpected error occurred while sending.”
I found topic about some reasons: Troubleshooting Schannel and TLS - Octopus Deploy, checked and applied the requirement. I updated Octopus Deploy and Octopus Tentacle to the latest versions. We use Windows 2016 on all machines.
I don’t see any reason why the Raygun Octopus Deploy integration doesn’t work. Please help me with this if you have a chance?

Hi @yura.nadolsky,

Thanks for reaching out and welcome to the community forum!

Based upon the error that you’re receiving it could be something to do with network appliances or security software or some sort of networking type issue.

Are you able to run some requests against the Raygun API outside of Octopus from the same machine that your Octopus is hosted on?
This should rule out or confirm Octopus as the cause of the issue and help to move you forward with troubleshooting.

Please let me know how this goes, or if you have any questions at all.

Kind Regards,

@adam.hollow Thanks for your reply.
I tried calling the same API on the same machine (with Octopus Deploy) using Postman and it worked. Postman called this API and I got a successful response.
But when I decided to call the same API from Octopus Deploy, it doesn’t work. I got the same error: “The underlying connection was closed: An unexpected error occurred while sending.”
Please help me with this issue.

Hi @yura.nadolsky,

Thanks for testing that, initially the thought was that a TLS cipher mismatch was occurring and halting the connection, but if the same machine can make a request from Postman then it is unlikely to be the case. This could only still be the issue if the deployment that runs the Postman API call is run on a deployment target (tentacle), rather than executed on the server itself.

Do you have a proxy server on your network at all? Is Octopus configured to run via a proxy for web requests?
You can identify if this is the case by opening Octopus Server Manager and reviewing the details presented, you can find out more on our docs page “Proxy support”.

Lastly and least likely to be the case it could be there were some system level changes on the Octopus Server machine that have not been picked up by the Octopus Server, such as an environment variable for a proxy. In this case, a restart of the Octopus Server service should allow Octopus to detect these changes.

Any information you can provide on the above would be helpful for troubleshooting and lastly, if possible, could you send over the process JSON for the Raygun API project within Octopus? That way I can review the configuration of the deployment process and see if I can spot anything that may be causing the issue.

If you’re able to, please upload the JSON here: Support Files | yura.nadolsky.

Kind Regards,
Adam