Deployment to WebApp staging slot


We are no longer able to deploy to Azure WebApp - staging slots. These were working as recently as March 17, but now fail with the “Microsoft.Web.Deployment.DeploymentDetailedException: Connected to the remote computer (“”) using the Web Management Service, but could not authorize.” error. Detail is attached.

Some more data / things I’ve tried:

  • We upgraded Octopus server from 3.2.4 to 3.3.6 yesterday. Because the last time we tried these deploys were March 17, we cannot be sure that nothing else has changed (like in the Azure framework, for instance)

  • We have three Azure environments in three Azure subscriptions, all of which previously deployed successfully to the staging slot.

  • Visual studio successfully deploys to all environments / all slots.

  • I’ve created a new Octopus project deploying a previously successful package, same results as above: Production slot = success, staging slot = failure.

  • In Azure, I’ve done a swap between the staging and production slots, the problem remains (cannot deploy to staging - the issue doesn’t move to production with the swap)

  • All environments and all slots have the WEBSITE_WEBDEPLOY_USE_SCM = false setting. I’ve tried changing this to true, it has no impact. When we initially set up this project, we did have to add this to the WebApp to get Octopus working.

  • In Azure, I’ve deleted and re-added the Octopus management certificate. In Octopus, all three Azure account settings “save and test” successfully.

  • The staging slots show up and are selectable in the Octopus Web App Step Details under Azure - Web App drop-down

Any other thoughts / things to try / data to gather?

-Chad Voelker (Johnson Controls)

ServerTasks-11799-REDACTED.log.txt (8 KB)

Hi Chad,
I have just tested a deployment to an Azure Web Ap (created via the new portal) deploying to a slot I created called Staging. The app appeared to deploy fine without any problems. Your logs make is sound like there is some sort of Auth issue with Azure. The Azure team have been making some big changes around Auth so it is possible that there could be a bug in there somewhere. It is quite odd that your Prod deployment works but Staging doesn’t since they should in theory share the same auth requirements and is certainly not a problem that any of us have come along.
Octopus essentially just executes WebDeploy which is the same mechanism that Visual Studio uses, so again all account information being equal they should give the same behaviour.
Do you get the same results if you create a new web app from scratch?

Yup, it looks like a relatively transient Azure problem. I created a new WebApp and deployed (success). I deployed to the two other WebApps that I was working with above (both success).

Thanks for your response. You can close this item.

-Chad Voelker