Deploy to dev failed

Hi team,

Post upgradation of our teamcity server while trying to deploy to dev we are getting the error as attached. Could you please check and advise. We have tried using different API keys as well.


Hi @user4,

Thanks for getting in touch!

To be able to investigate this fully it would be useful to have the full build log for this step to examine. Would it be possible to attach that for us?

Also, are there any other Octopus steps within this build pipeline that are working correctly? Such as “Push Package to Octopus Server”?

When you tried different API keys, did these API keys belong to different users or were you regenerating new API keys for a single user?

Lastly, what version of Octopus Server are you currently running?


Hi Paul,

Apologies as I won’t be able send complete build log, Only a few build are getting failed with the error. We generated API Keys from different user accounts. Octopus server version is windows 2012R2.


Are there any significant differences between the builds that fail and the ones that succeed? Are they using different API keys?
It might be worth checking the permissions on the users for these API keys to ensure that they have the ability to create releases in the relevant projects.

You could also try creating a generic user account with full system admin permissions and using an API key from that user to try and rule out any permission issues.

If you can’t share the entire build log, would you be able to at least show the octo.exe command that is being run for that step? I believe it is the line above where your screenshot begins.

Hi Paul,

I have attached the screenshot for your reference.

The API key generated accounts belong to octopus administrators group.


Nothing is standing out as being incorrect here.

Along with the TeamCity upgrade were any other changes made, such as upgrading the Octopus version or plugin version?

The only other test that may be worth trying would be to download the Octo CLI and try using the create release command outside of TeamCity to see if you encounter the same issue.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.