Deploy Kubernetes image without service port

(Hakan Lindestaf) #1

I have a kubernetes image (background scheduler basically) that doesn’t have a service port, it’s not listening to any requests. I can’t seem to add it in a step without specifying at least one service port.

(Matthew Casperson) #2

Hi Hakan,

The definition of a service is optional. If you click Configure Features and untick the options that don’t apply, those resources won’t be created as part of the deployment.

In the screenshot below you can see a deployment step that has none of the additional features enabled.

Regards
Matt C

(Hakan Lindestaf) #3

Cool, that worked, didn’t realize the features settings were related. Thanks!