Delta Compression and pre-compiled pages

Hi, we have just noticed a problem when we deploy a web site using pre-compiled pages. Some of the files have been changed, but these are not being pushed with each release.
I wondered if it was due to delta compression not recognising the change.
Have you heard of this issue before, or do you know any reason why not all pages are being deployed?
Thanks
Richard

Hi Richard,

Thanks for posting your question, and sorry you’re experiencing that issue.

I’m not aware of any current issues that might cause this behavior, so I hope you don’t mind if I get some more information so I can further assist in troubleshooting this issue.

To look further into this, could you provide me with a recent task log from a project where you saw this occur?

Alongside that task log, let me know which packages you were expecting to update/deploy that may not have been updated properly.

Also, an export of your deployment process would be helpful if you’re able to provide that as well. We can use this for reviewing your process and testing on our end if needed.

You can use the following link to securely upload these: Support - Octopus Deploy

Let me know once you’ve done that I’ll take a look at them.

Best,
Patrick

Thanks Patrick, with the Christmas break, I’m only just getting back to this. Unfortunately the release from 7/12/2021 has been deleted, so it’s not obvious how to get to the log for it.
I just tried to upload the deployment process, but the link given above has expired
Richard

Hi @richardboyce,

Thanks for getting back in touch!

Unfortunately, those file upload links do expire after a week; not to worry, though, I’ve created you a new one here: Support Files.

Please let us know when you’ve been able to upload the deployment process.

I hope you had a great Christmas break!

Kind Regards,
Adam

Thanks Adam. Good break, thank you. Hope you had a good one too.
I have uploaded the deployment process now.
Richard

Hi @richardboyce,

Thanks for uploading the process!

While I’m looking into this, is there any chance you’d be able to deploy a new release of the project?

Even if the updates fail to make it across, the task log for that deployment would be invaluable to furthering our troubleshooting.

Apologies; I should have asked you for this earlier but I hadn’t considered you may be deploying to a dev or test environment. If this isn’t the case and you cannot deploy a new release then let me know and we can go from there.

Kind Regards,
Adam

Hi Adam, I’ve just uploaded the log. I haven’t checked whether the files were all deployed correctly.
Richard

Good afternoon @richardboyce,

Thank you for uploading those logs, we have had a look at them and can’t see anything obvious. It may be that that deployment worked and had all the packages displayed correctly.

I was wondering if you were able to check some other things for us to help narrow down the issue.

It seems very unlikely that it’s delta compression causing it, we do a checksum-based difference there so that would have been picked up in the logs.

If you could download the files out of the feed and inspect them. If it has the wrong contents, then check the artefact from your build server and see if they’re right there.

It’s very likely that a) the package contains the stale data, or b) there’s some network-level caching going on.

We need to track down at what point in the build/deployment/operation pipeline the stale data is showing up as that will be the key to solving this issue for yourselves.

Let me know what you find and please reach out in the meantime if you have any other queries.

Kind Regards,

Clare Martin

Thanks Clare. The error happened before Christmas and we don’t have access to the deployment logs any more. From memory, we checked the contents of the build artefact and they contained the correct files, which is why we suspected the compression. We couldn’t explain it any other way.
It’s very hard to spot when this fails, but we’ll wait for the next failure and check everything we can
Richard

Good morning @richardboyce,

Thank you for getting back to us with that, intermittent faults are the most annoying and difficult to diagnose but we will keep an eye out on the forum for any updates and as soon as you notice anything let us know and we will have a look at the logs and see where we can pinpoint the issue.

Thank you for your patience throughout this process, hopefully, it will happen again soonish so this post will remain open but feel free to open another post if this one closes and you have an update.

Anything else you need in the meantime please reach out!

Kind Regards,

Clare Martin

1 Like