Custom install directory Bug

I have setup a custom install directory for my package, saved it and then created a new release with a new deployment. Octopus still deploys using the default install directory at C:\Octopus\Applications[Environment][Project][Version]. This is using the latest version 3.3.1. I tried a few things but none of them worked:

  • Use a very simple simple path e.g. C:\Foo
  • Turning the purge on and off.
  • Push a new NuGet package to Octopus and do a new release off that.


Thanks for getting in touch.

I tried to reproduce this in 3.3.1 but I had no luck. In both deployments it consistently deploys to the same custom directory I set when deploying the first time. Also no one else has reported this so far, and we are talking about one of the most used features.

Could you please follow the steps below to provide us with a verbose deployment log?

  1. Add these 2 variables to your project

  2. Create a new release (so the new variables take effect) and deploy it. If possible skip as many steps as you can and only leave step we are troubleshooting in order to avoid the noise in the log.

  3. Send us the raw log of that deployment

I’m gonna need you to follow this process twice for 2 consecutive releases/deployments.

Once you are done, please attach both logs to this ticket. Feel free to set it as Private so only our staff and you can see its contents

Best regards,