Create Release - Latest package not found - V2

I upgraded to V2.0.9.1020 from V1.6 and Create Release now returns ‘Not found’ in the ‘Latest’ box.
So I have to do a ‘Specific’ search and select the latest package that way.

Hi Jeremy,

Thanks for letting us know. Do you have a large number of a) pre-release packages of b) “deleted” packages with the same ID?

If you’re able to grab the Octopus Sever log file ( and send any relevant errors that might help us get to the bottom of it too.

Many thanks!

I don’t have any pre-release packages AFAIK
I’ve deleted a lot of old packages manually if that makes a difference.
We are using TFS and our packages are created using Octopack

OctopusServer.txt (2 MB)

Thanks - everything looks pretty healthy in there.

Is it possible the case of the package ID is different in the Step definition from the NUPKGs/NuSpecs? Windows file shares are case sensitive to NuGet, so it is possible there’s a glitch there somewhere.

If this doesn’t turn up anything, can you please let me know which browser you’re using?


Thanks Nick,

Matching the case sorted it!

There is no file share, just a folder - as my octopus is on the TSF build server, but anyway that fixed it.


Same issue here, removed all versions of the nuget package and readded the step. Now it works.