Create Octopus Release Fails when other build projects it works fine

(Richard Albrecht) #1

Using Azure DevOps Server 2019 Update 1 with Octo.exe 4.30.3 Octopus Server Version 3.17.0
Output from the Azure DevOps Create Release Task below:

##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --project="Deploy TitleCustody"
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --channel="Release"
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --server=http://octopus.merchantsfleet.com/
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --apiKey=***
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --enableServiceMessages
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --deployTo="BusSys_Dev"
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --progress
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --releaseNotesFile="D:\do_agent2\_work\16\s\release-notes-889b1680-edcb-11e9-acfe-65d000344885.md"
##[debug]D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd arg: --apiKey=***  -deploymenttimeout=00:20:00 --ignoreSslErrors
##[debug]exec tool: D:\do_agent2\_work\_tool\Octo\4.30.3\x64\Octo.cmd
##[debug]arguments:
##[debug]   create-release
##[debug]   --project=Deploy TitleCustody
##[debug]   --channel=Release
##[debug]   --server=http://octopus.merchantsfleet.com/
##[debug]   --apiKey=***
##[debug]   --enableServiceMessages
##[debug]   --deployTo=BusSys_Dev
##[debug]   --progress
##[debug]   --releaseNotesFile=D:\do_agent2\_work\16\s\release-notes-889b1680-edcb-11e9-acfe-65d000344885.md
##[debug]   --apiKey=***
##[debug]   -deploymenttimeout=00:20:00
##[debug]   --ignoreSslErrors
Handshaking with Octopus server: http://octopus.merchantsfleet.com/
Handshake successful. Octopus version: 3.17.10; API version: 3.0.0
Authenticated as: TFS Build <> (a service account)
This Octopus Server supports channels
Finding project: Deploy TitleCustody
Building release plan for channel 'Release'...
Finding deployment process...
Finding release template...
The package version for some steps was not specified. Going to try and resolve those automatically...
Finding latest package for step: Deploy Placeholder Package
Selected 'Merchants.TitleCustody.Deploy' version '2019.10.13.7-mainTitleCustody' for 'Deploy Placeholder Package'
Finding latest package for step: Deploy Octo Command Line Tool
Selected 'OctopusTools' version '4.5.0' for 'Deploy Octo Command Line Tool'
Using version number from package step: 2019.10.13.7-mainTitleCustody
Release plan for Deploy TitleCustody 2019.10.13.7-mainTitleCustody
Channel: 'Release' (this is the default channel)
  #   Name                            Version                         Source             Version rules          
  --- ------------------------------- ------------------------------- ------------------ -----------------------
  1   Deploy Placeholder Package      2019.10.13.7-mainTitleCustody   Latest available   Range: PASS Tag: PASS  
  2   Deploy Octo Command Line Tool   4.5.0                           Latest available   Allow any version      

Creating release...
Release 2019.10.13.7-mainTitleCustody created successfully!
setParameter name='octo.releaseNumber' value='2019.10.13.7-mainTitleCustody'
##[debug]Processed: ##vso[task.addattachment type=Distributedtask.Core.Summary;name=Octopus Deploy;]D:\do_agent2\_work\16\s\7f59e544-08cb-4afa-9f49-4ae00bb8cf5f.md
Deploying Deploy TitleCustody "2019.10.13.7-mainTitleCustody" to: BusSys_Dev (Guided Failure: Not Enabled)
Waiting for 1 deployment(s) to complete....
         Info    Acquiring packages   {Message:l}
Info    Making a list of packages to acquire   {Message:l}
Info    Delta compression is enabled for package transfers from the Octopus Server to deployment targets   {Message:l}
Info    Package Merchants.TitleCustody.Deploy.2019.10.13.7-mainTitleCustody was found in cache. No need to download.   {Message:l}
Info    Package OctopusTools.4.5.0 was found in cache. No need to download.   {Message:l}
Info    All packages have been acquired   {Message:l}
                        Info    Found matching version 2019.10.13.4-mainTitleCustody: D:\Octopus\Packages\Merchants.TitleCustody.Deploy\Merchants.TitleCustody.Deploy.2019.10.13.4-mainTitleCustody.nupkg   {Message:l}
Info    Uploading package Merchants.TitleCustody.Deploy (2.303 KB)...   {Message:l}
Info    Beginning streaming transfer of Merchants.TitleCustody.Deploy.2019.10.13.7-mainTitleCustody.nupkg-e6b5d096-35b8-4ce3-9dcf-bf4928f8346d   {Message:l}
Info    Stream transfer complete   {Message:l}
               Info    Using package D:\Octopus\Packages\Merchants.TitleCustody.Deploy\Merchants.TitleCustody.Deploy.2019.10.13.4-mainTitleCustody.nupkg with hash 2db3b8726fc9ba026c9f2e60d0f538722571121f for creating delta.   {Message:l}
Info    Original package was 2.303 KB, delta file is 2.353 KB (-2.16% size reduction).   {Message:l}
Info    Generated delta file size was within 80% of the full package, going to upload the entire package.   {Message:l}
             Info    Package OctopusTools.4.5.0 (752.387 KB) found in cache. No need to upload this 752.387 KB package. Using D:\Octopus\Files\OctopusTools.4.5.0.zip-6789c2da-4073-48bd-be2e-977c40a54a45   {Message:l}
                    Info    Deploying package 'D:\Octopus\Files\Merchants.TitleCustody.Deploy.2019.10.13.7-mainTitleCustody.nupkg-e6b5d096-35b8-4ce3-9dcf-bf4928f8346d' to machine 'https://m1wappods01-p:10933/'   {Message:l}
Info    Deploying package:    D:\Octopus\Files\Merchants.TitleCustody.Deploy.2019.10.13.7-mainTitleCustody.nupkg-e6b5d096-35b8-4ce3-9dcf-bf4928f8346d   {Message:l}
                    Info    Deploying package 'D:\Octopus\Files\OctopusTools.4.5.0.zip-6789c2da-4073-48bd-be2e-977c40a54a45' to machine 'https://m1wappods01-p:10933/'   {Message:l}
Info    Deploying package:    D:\Octopus\Files\OctopusTools.4.5.0.zip-6789c2da-4073-48bd-be2e-977c40a54a45   {Message:l}
         Fatal   The step failed: Activity Deploy Title Custody ClickOnce on M1WAPPODS01-P failed with error 'The remote script failed with exit code 1'.   {Message:l}
           Info    Executing script on 'M1WAPPODS01-P'   {Message:l}
Info    Attempting to load .NET DLL D:\Program Files\Octopus Deploy\Tentacle\Octopus.Client.dll...   {Message:l}
Info    Loaded .NET DLL D:\Program Files\Octopus Deploy\Tentacle\Octopus.Client.dll.   {Message:l}
Error   new-object : Exception calling ".ctor" with "2" argument(s): "An Octopus    {Message:l}
Error   server URI was not specified."   {Message:l}
Error   At D:\Octopus\Work\20191013151018-295349-99\Script.ps1:39 char:13   {Message:l}
Error   + $endpoint = new-object Octopus.Client.OctopusServerEndpoint    {Message:l}
Error   $octopusURI,$apikey   {Message:l}
Error   +                {Message:l}
Error   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~   {Message:l}
Error       + CategoryInfo          : InvalidOperation: (:) [New-Object], MethodInvoca    {Message:l}
Error      tionException   {Message:l}
Error       + FullyQualifiedErrorId : ConstructorInvokedThrowException,Microsoft.Power    {Message:l}
Error      Shell.Commands.NewObjectCommand   {Message:l}
Error      {Message:l}
Fatal   The remote script failed with exit code 1   {Message:l}
Fatal   Deploy Title Custody ClickOnce on M1WAPPODS01-P   {Message:l}
                  Info    Apply retention policies...   {Message:l}
                        Info    Keeping this deployment and the previous 5 successful deployments   {Message:l}
Info    Removing directory 'D:\Merchants\Apps\BusSys_Dev\Merchants.TitleCustody.Deploy\2019.10.12.2-mainTitleCustody_1'   {Message:l}
Info    Removing package file 'D:\Octopus\Files\Merchants.TitleCustody.Deploy.2019.10.12.2-mainTitleCustody.nupkg-fe48d235-474d-4d27-a53d-baff693642ce'   {Message:l}
             Info    Keeping this deployment and the previous 5 successful deployments   {Message:l}
Info    Removing directory 'D:\Merchants\Apps\BusSys_Dev\OctopusTools\4.5.0_3'   {Message:l}

Deploy Deploy TitleCustody release 2019.10.13.7-mainTitleCustody to BusSys_Dev: Failed, The deployment failed because one or more steps failed. Please see the deployment log for details.
One or more deployment tasks failed.
This error is most likely ocurring while executing Octo.exe as part of an automated build process. The following doc is recommended to get some tips on how to troubleshoot this: https://g.octopushq.com/OctoexeTroubleshooting
Exit code: -1
(Shane Gill) #5

Hi @richardalbrecht,

Thanks for getting in touch.

From the looks of the logs you have sent it looks to me like a release and deployment are being created, but the deployment is failing.

The step “Deploy Title Custody ClickOnce” is failing, can you let me know a little bit more about what that step is doing? The deployment task log for the project TitleCustody version 2019.10.13.7-mainTitleCustody should help troubleshoot what went wrong.

Cheers,
Shane

(Richard Albrecht) #6

[https://help.octopus.com/user_avatar/help.octopus.com/shane_gill/45/23301_2.png]
Shane_Gillhttps://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhelp.octopus.com%2Fu%2Fshane_gill&data=02|01|richardalbrecht%40merchantsfleet.com|11a00a9387124e0b47ae08d7504a56ab|74e16038e7dd4392b38a5a2b6d6e3a25|0|0|637066152528692967&sdata=QCwgUZG8CG08QYoE9G8MIMZW%2FAMxEkv4uxXRFe2aTm8%3D&reserved=0
October 14

Hi @richardalbrechthttps://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhelp.octopus.com%2Fu%2Frichardalbrecht&data=02|01|richardalbrecht%40merchantsfleet.com|11a00a9387124e0b47ae08d7504a56ab|74e16038e7dd4392b38a5a2b6d6e3a25|0|0|637066152528702959&sdata=25WTDcDpgl6iaPJ6lHayfvPAenMeaLwvnLwcMuPilJQ%3D&reserved=0,

Thanks for getting in touch.

From the looks of the logs you have sent it looks to me like a release and deployment are being created, but the deployment is failing.

The step “Deploy Title Custody ClickOnce” is failing, can you let me know a little bit more about what that step is doing? The deployment task log for the project TitleCustody version 2019.10.13.7-mainTitleCustody should help troubleshoot what went wrong.

Cheers,
Shane

ServerTasks-295391.log.txt (25.3 KB)

(Shane Gill) #7

Exception calling “.ctor” with “2” argument(s): “An Octopus 20:10:25 Error | server URI was not specified.”

It looks like the step is running a PowerShell script that attempts to call Octopus.Client but a server URI is not specific? What does the script look like?

Cheers,
Shane

(system) closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.