Couldn't connect to my local Octopus server (SQLEXPRESS)

integration

(Omar Alodaini) #1

I am trying to deploy a web app on VSTS. I am using Octopack and have .nuspec file and PostDeploy.ps1. On 'create Octopus Release, I always get this output:

IIS 10.0 Detailed Error - 404.0 - Not Found . . 2018-09-03T14:55:12.2447026Z Error from Octopus server (HTTP 404 NotFound) 2018-09-03T14:55:12.2447266Z Exit code: -7 2018-09-03T14:55:12.2650037Z ##[error]Error: C:\hostedtoolcache\windows\Octo\4.38.1\x64\Octo.cmd failed with return code: 4294967289 2018-09-03T14:55:12.2664398Z ##[error]Failed to deploy release C:\hostedtoolcache\windows\Octo\4.38.1\x64\Octo.cmd failed with return code: 4294967289

I think that it is unable to connect to my local octopus. I used ‘http://localhost:80/’ and ‘http://localhost/app#/’ as Server URL and both did not work.

my MSBuild Argument is : /p:RunOctoPack=true /p:OctoPackPackageVersion=$(Build.BuildNumber).0

Please Help !!


(Omar Alodaini) #2

By the way, the tentacle I am using is localhost too on another port.


(Henrik Andersson) #3

Hi Omar,

Thanks for getting in touch. Could you provide me with some further information to help us troubleshoot this issue for you.

  • How is the generated package pushed to your Octopus Server?
    • Are you using OctoPack, or
    • are you using our Push Package step from our VSTS extension?
  • VSTS build definition
    • Can you send through some screenshots of how you’ve configured your build in VSTS
  • Octopus Service Connection configuration in VSTS.
    • Can you send through a screenshot of how you’ve configured the Octopus service connection in VSTS
  • Are you running a local VSTS build agent?
    • If you are not, then http://localhost won’t work as the build agent won’t be able to connect to your Octopus server using localhost

The error IIS 10.0 Detailed Error - 404.0 - Not Found seems to indicate that the URL used for the Create release step is being served up by IIS and not Octopus as we don’t run under IIS.

Thank you and best regards,
Henrik


(Omar Alodaini) #4

Here are my settings:


(Omar Alodaini) #5

I am running the build on : https://*****.visualstudio.com/


(Henrik Andersson) #6

Hi Omar,

Thanks for the extra information.

As you’re running your builds on VSTS which runs in the “cloud” it wouldn’t be able to connect to your local Octopus using http://localhost (that URL would be pointing to the build agent itself that the step is running on) so you’d have to configure the connection to your Octopus server using either a publicly accessible IP or DNS name.

I hope that helps.

Thank you and best regards,
Henrik


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.