Cluster 'cluster-name' could not be found

Hi there

We are planning to use Octopus Cloud for our team. So we are trying it so far.

In the infrastructure tab → Accounts I defined an AWS account for octopus that has admin access. Then I created a deployment target with that AWS account information.

That EKS cluster we have in AWS is created with vpc and subnets and it also has public server endpoint access. And it is alive on AWS without error

But this deployment target in octopus cloud can not reach aws and I get that error in the connectivity part

Do I miss some configuration?

Hi @sercan,

Thanks for reaching out to Octopus Support!
Welcome to our community forums!

As you’re using a cloud instance, would you mind if we created a support user so we can take a look at the configuration you currently have?

Let me know if this is alright, as it could help us achieve a faster resolution.

Kind Regards,

Yes please. It would be so helpful

Hi @sercan,

Thanks for getting back to me!

I had a look at your instance, and it looks as though the account you have has been set up correctly.
It looks as though Octopus cannot connect to the cluster you’ve specified in the target settings.

Are you able to verify that you can connect to this cluster from your local machine?
There may be some network security rules on the AWS side that block our Dynamic Workers from reaching the cluster.

I hope this helps! Please update me on your progress once you’ve had a chance to look over and test the connection, and we can proceed from there if your issues are not resolved.

Thanks and Kind Regards,

Hi Adam,

Thank you for your kind answer. I installed kubectl cli and aws cli on my computer. When I type

kubectl get nodes,

I can list my nodes and all of the statuses of them are ready. In aws part, my cluster is public. Also, I just have public zones and subnets. I didn’t configure any private options in my configuration to be sure not to block anything from octopus.

Hey @sercan,

Thanks for checking that out!

Would you be able to double-check the region and the display name of the cluster and verify you’ve entered the same in octopus?

This is to be sure that everything is lined up correctly, as I can’t see any reason that the connection would be blocked or otherwise disrupted if the cluster is open and you’re able to connect via a local machine.

Kind Regards,

Hey Adam

Last night we found the solution. When I create the deployment target I choosed the AWS because I use Aws :smiley: But that creating option in octopus provides for ECS, not EKS that was the reason octopus checked the cluster but can’t find it. Then we created our deployment target by Kubernetes Cluster and it connected. At least I can see the health check is okay from connectivity. So as feedback, these kinds of small tips can be useful for the users in creating deployment target UI to find something easily.

Thank you so much again for your kind answers and see you again in other problems that we gonna face :smiley:

1 Like

Hi @sercan,

Thank you for letting me know you found the solution and for your feedback and kind words!

We’re always happy to help if you have any questions or issues; please don’t hesitate to get back in touch if you do!

Kind Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.