Certificate Step Template Parameter not expanded?

Currently we are trying to create a step template that adds a Trusted CA Cert to centos machines.
Its setup and works by: Selecting a Target (Centos machine), selecting certificate to import, and writing out the download path.

The script runs successfully and creates a .crt file but when going to machine the .crt file is empty with nothing. It seems like the issue stated here

But I saw that issue was fixed in 13.3.4 and we are on version 2022.1.2584.

Here is our script below:

Hi @tcochran,

Thanks for getting in touch! I’m sorry to see you’re hitting this unexpected behavior. I’ve done some testing here, and while it ended up working successfully and as expected when adding the step template to a project’s deployment process, I did see some incorrect results when running the step template standalone.

What I saw locally when running the step template was certificate parameters not populating certificates for selection for that parameter. I added this issue to a bug report I raised earlier in the same area.

When adding this template to a project, the expanded properties (CertificatePem) does exist and writes to the .crt file created in the script.

Could you let me know how you’re running this step template? E.g. standalone from the step template itself, or is it included in a project’s deployment? Would you be willing to share task logs from a run that’s showing this issue? Hopefully we can figure out what’s causing this issue with that additional information. :slight_smile:

Best regards,


Thanks for the response,

I am running it standalone from the step template itself. I could try from projects deployment but need to consult with my team on that next week.

task log:
ServerTasks-765321.log.txt (5.2 KB)

1 Like

Ok, so tested script in a runbook for a project and it worked properly. It would be cool if it worked standalone but this works for now. Thanks again for the help.