Can't upgrade Octopus Portal when the site has multiple bindings

I tried to upgrade the Octopus Portal after a server upgrade. The site is setup with two bindings

  • *:8083
  • octopus.internal.domain:80

The first binding is the one used in the configuration tool. When I hit the upgrade button it failed. When I removed the binding octopus.internal.domain:80 the upgrade worked fine.


Thanks for letting me know! I’ll fix it in the next release.


Hi Paul,

Thanks for the reply! Keep up the good work, I’ve been wanting this kind of tool for quite a while. I really like it.

I commented a card on Trello, which actually was a question about grouping of environments. Maybe I should’ve posted that somewhere under suggestions instead?

Best regards,

27 aug 2012 kl. 17:36 skrev "Paul Stovell"

Hi Anders,

This has been fixed in the latest version. The installer shows the port of the first binding and will update that binding if the port changes. If that first binding has a hostname specified, that hostname will remain unchanged.


I confirm that it is fixed! Thanks alot!

Best regards

Mvh Anders

11 dec 2012 kl. 17:14 skrev "Steven Kuhn"