Build information

Hi
I am using Octopus Deploy plugin 3.1.3 in Jenkins. I’ve develop branch. when I commit to this branch, the build information generated properly.

However, the first time I create a branch from “develop” the build information for the new branch
shows unknow on vcsType and empty commits. Is this normal?

Hi @endashaw.adane

That doesn’t sound normal - however it sounds like something that we are doing incorrectly in our code, as opposed to something that you may be doing wrong. I’m going to attempt to reproduce this over the next couple of days to see if I can track down the culprit.

Sorry for the delay in getting back to you.

Regards,

Dane.

@Alex.Rolley ,

Thank you for checking this issue.

Regards,

Endashaw

Hi @dane.falvo ,

Any update on this issue?

Regards,

Endashaw

Hi @endashaw.adane,

Sorry for the delay, I am still progressing with identifying the cause of this issue. Once the issue is identified, I will raise a public issue that I will provide to you so you can follow through with any updates.

We have identified a part of the code base that may be the culprit, that I will investigate over the next couple of days and will hopefully have a public issue by the end of the week.

Regards,

Dane

Hi @endashaw.adane

I’ve created a public issue and have had an engineer check over the section of code to make sure that our assumptions were correct.

You can get all the info about the issue as well as subscribe to any updates, here: Committing to a New Branch to Github using Jenkins Octopus Deploy Plugin doesn't populate Commit Comments or VCSTypes · Issue #6822 · OctopusDeploy/Issues · GitHub

Thanks for the report! I really appreciate the effort that you put in.

Regards,

Dane