Bug? Library Variable Sets list showing Script Templates too

(dwhite) #1

The Library - Variable Sets display shows the first 30 library variable sets. If we wish to see a variable set that is not displayed in the first 30, we use the Filter by Name feature, or the LOAD MORE link at the bottom of the page.

The problem is that either of these 2 strategies loads the Script Templates as well as the Variable Sets!

Screenshot from the initial display of the Variable Sets list:

image

Screenshot after clicking the LOAD MORE link, showing the Script Templates included:

image

thanks,
David

(Nick Josevski) #3

Hi David,

Thanks for getting in touch. I tested in 2018.8.8, 2018.12.1, 2019.1.8 and could not reproduce the issue.

Are you on a version in between those? It’s possible it was introduced and fixed without an issue being raised. Can you upgrade to 2018.12.1 or later and let me know if it still occurs for you?

Regards,
Nick

(dwhite) #4

Hi Nick,

Earlier this week we upgraded to v2018.10.3LTS, as recommended on the download site. The same error occurred on v2018.8.8 for us. (Moving to v2018.12.1 or higher will have to wait at least until next week.)

I suspect that the error might not show up if you have less than a pageful of Library VariableSets? But then again, filtering causes the bug to show up, too.

regards,
David

(Nick Josevski) #5

Hi David,

Thanks for the additional information, I would like to keep investigating and I would really appreciate your help when you can.

I test with 35 variable sets and 2 script step templates.

Could I get your help with some more answers and for you to send me some samples of JSON of the offending step template?

  • How many library variable sets do you have?
  • How many step templates do you have?
  • How many step templates show up unexpectedly?
  • Do you notice anything common about the step templates that show up compared to others that don’t?
  • Can you navigate to the Step Template that’s showing up on the variable listing page
    • Open the browser network tab and look for the network call that’s for an ActionTemplates-X and send me the JSON in the response.
    • If there’s anything sensitive in there, just take out those bits.

Regards,
Nick

(dwhite) #6

Hi Nick,

Oh, I think I have used the wrong terminology. They are Script Modules that are showing up in our list of Library Variable Sets - not Step Templates.

Looking in the dbo.LibraryVariableSet table, we have 62 library variable sets and 10 script modules. (Does that answer your first 2 questions?)
All 10 script modules show up in the list after clicking on LOAD MORE 2x to display the whole list.

Let me know if there are any other things you wish me to examine.

thanks,
David

(Nick Josevski) #7

Hi David,

Thanks for that tip. That’s a bit embarrassing, it seems like we’ve had this bug for a very long time. Thanks for reporting it. The fix will likely be somewhere in 2019.1, stay tuned to this github issue.

From the looks of it will be annoying/confusing, hopefully you can just work around it until we can patch it.

Let us know if you need any further help.
Regards,
Nick

(Nick Josevski) #8

Hi David,

Just to let you know that the fix for this issue has shipped in 2019.1.10.

Regards,
Nick

(dwhite) #9

Hi Nick,

Thanks to the team for the quick fix. We’re happy to be the catalyst for continual improvement. :slight_smile:

warmly,
David

1 Like
(system) closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.