Block deployment not working

Seems to be an issue since upgrading to 3.2.1. Blocking a deployment has no effect. The deployment button is still present and clicking it will result in the deployment running.

Hi Michael,

At first I couldn’t replicate your issue, but then I moved my environments into the same Lifecycle Phase and the behavior was as you describe.

Are your environments in the same Lifecycle Phase?

I agree this is incorrect, and I have raised an issue which we will resolve.

Thank-you for reporting this.

Michael R

They are in separate phases but it is a life cycle that was imported from 2.6. I will try recreating the life cycle and see if the issue persists. I’ll let you know what I find.

Sent from my LG G3, an AT&T 4G LTE smartphone

I tried creating a new life cycle that didn’t exist previously but it made no difference. Still the block release has no effect. I also had a hard time since most of our releases use life cycles that have automatic release creation and none of them can be changed as I’m hitting this bug.

A little bit more information:
Apparently this is by design. The rules are, once a release is blocked, it can still be deployed to environments in the same or earlier lifecycle phases. But it cannot be promoted to a later phase.

If you are able to deploy a blocked release to environments in later lifecycle phases, then that is a problem.

Regarding that bug, it has now been resolved in the latest release.

Michael R

Thanks Michael, I’ll install 3.2.2 and take a look. I didn’t see it in the release notes though. Also, what do you guys use fit the release note diff? That’s a pretty cool feature.

Sent from my LG G3, an AT&T 4G LTE smartphone

Oh, perhaps you could clarify. Are you saying the issue with the blocked deployments has been fixed in 3.2.2 or the error about the channels? The issue is definitely happening with a phase that is later in the life cycle. I noticed it because we block failed release candidates in staging so the aren’t mistakenly deployed to production.

Sent from my LG G3, an AT&T 4G LTE smartphone

Sorry, the channels error has been resolved.

That’s very interesting about the blocked deployments. The environment that you are able to deploy to (production/uat) definitely isn’t present in the current or any earlier phases? Are you able to attach a screen-shot of your lifecycle?

The release notes diff is nice right (I can say that since I didn’t work on it)? It’s some custom in-house code. I wish every product had one.

Here you go

Hi Michael,

I was again attempting (and failing) to replicate this, but I had an idea: when we introduced Channels (in 3.2), it became possible to override the Lifecycle for a Project, by setting it on the Channel. Is it possible that the Lifecycle has changed on the Channel and isn’t using the Lifecycle shown above?

We haven’t started using channels yet so it is set to the default channel and that channel is set to inherit the lifecycle from the project. We’re on 3.2.6 now and it seems to have been resolved somewhere along the way. I’ll post back if it happens again. Thanks for your help!