Audit report not displaying LibraryVariableSet changes

modelling

#1

It looks like after our last update (currently 2018.3.13) we lost the ability to run audit reports on the LibraryVariableSets document type. I can see the entries listed in the Event table that I am trying to display. Is this a known issue that we need to schedule an upgrade to resolve? I haven’t seen any related errors or exceptions in the log that are related, just no results being returned.


(Kenneth Bates) #3

Hi Waldo,

Thanks for getting in touch! I’m sorry to hear you’re hitting this unexpected behavior here. I’m not aware of any reported issue that’s related. I’ve given this a test and it seems to work as expected in my local instance. Would you be able to provide a screenshot of the audit page when using the filter? Are you filtering by anything else outside of the LibraryVariableSets document type?

For the time being, would filtering by the Variable Set document type work? This type includes library variable set events, but also project variable events, so it won’t be ideal.

I look forward to hearing back and getting to the bottom of this one!

Best regards,

Kenny


#4

Here is a screenshot of the DB query for the library variable set change I’m trying to display in the audit report.


Below is the audit report range that I believe should display the record from the db. Even when I run the report filtered down to the specific user that made the change I don’t see any related entries.

Please let me know if there is any more information that I could provide on this issue.