All Tenants not available while propagating from one environment to other

usability
(shaik sadiq) #1

Hi Team,

I had created a lifecycle as follows:
image

And here CIT42 environment has tagged with tenant A, B, and C.
and UAT42 environment is tagged with B, C, D.

but when I Propagate a release from CIT42 to UAT42 the required tenants will not be available, but i am getting only tenant “B” in the drop down, shown in below image.

How to get all the applicable tenants for a particular environment while propagating same release number from one environment to other.

My whole intention is that all the builds should follow the phases, any environment should not be skipped. so all the release propgation should start from CIT42 and end at PRD42.

NOTE: if i add all the environments in one single phase, then it is working fine, but my team will skip some environments and deploy to UAT42, PPD42 OR PRD42 (which needs to be restricted).

It would be of great help if a solution is provided to this.

Thanks,
Shaik Sadiq

(Kenneth Bates) #3

Hi Shaik Sadiq,

Thanks for getting in touch and providing all of that helpful info! What I currently suspect may be happening is that only Tenant B has gone through the lifecycle progression whereas the others haven’t yet. Each tenant has to individually progress through each lifecycle phase.

Could you send a screenshot of your project’s Overview page? This will give me some more context in understanding your scenario, showing deployments to each of your tenants and their progression.

Alternatively, I notice from your screenshot that you’re deploying a release in the 4.2_Milestone_Channel_Manual channel, so perhaps there’s a mismatch between the tenant tag this channel is scoped to, and the tags that these missing tenants are in. If this sounds possible, could you also send screenshots showing this channel’s configuration, and also of one of these specific tenants you’re expecting to see in the deployment dropdown?

I look forward to hearing back and getting to the bottom of this one!

Best regards,

Kenny

(system) closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.