All projects/Environments gone after upgrade to

I was on 1.6.0 and upgraded to

Now when I go to the portal it appears like a completely new installation. All my projects and environments are gone!

If I look at the raven db management studio, it looks like things still seem to be there.

And if I run a health check, all the machines in my old environment get checked still.

How do I get my projects back?


This shouldn’t happen.

Can you go to the Raven management studio, then the Indexes tab, and reset all of the indexes? Then restart the Octopus windows service so that it re-creates all of the indexes, and see if that resolves the issue.


I saw that solution in a different post. I tried it but it didn’t work.

If I look in the ‘Task’ section I can still see old deployments too. And if I click on them I can still get to the project data that way. Unless I try and click on Environment, then it just goes to the environment screen where it just says “To get started…”


Thanks. Would you be available to share a screen with me and we can try to walk through it? My Skype handle is paulstovell but let me know if there’s a different screen sharing technology you’d like to use (or a time that works better).


I don’t use skype but I can send you a teamviewer invite if you have an email I can send it to

Sure -


Paul Stovell
Octopus Deploy
W: | T: @octopusdeploy

That’s “paul at