404 Error after creating release in a project and also viewing release

I am getting a 404 error after creating a release on my projects, the release is created successfully.

URL is /projects/MYPROJECT/releases/edit

If I attempt to view the release I also get a 404

URL /projects/MYPROJECT/releases/

Odd I think I have worked it out, you need a proceeding / on hte URL

/projects/MYPROJECT/releases/ == worked

/projects/MYPROJECT/releases/ == 404

Hi Nikolai,

That sounds like maybe something is wrong with the configuration - a trailing slash should make no difference.

Which version of IIS and Windows are you using to host the Octopus Deploy server?

Will you be free to do a Skype call with me sometime to debug the issue? Let me know a time that works for you.


Hi Nikolai,

Can you send a screenshot of the role services that are installed under IIS 7? I think there may be some extra features that are required. For reference, here is what I use:

Role services


We have Octopus deployed on a fresh Win2K8R2 box, we were missing some of the role services mentioned but I have since added with no change in behaviour.

I have sent a skype request, there will be some timezone difficulties as I am in NZ.

Thanks for your assistance, the solution was that we needed to add HTTP Redirection to the Common HTTP Feature section. Everything is working fine now.