Deploy a Release step - No deployment targets available

modelling
(rohin.mcdermott) #1

I’m almost certain I’ve missed something obvious, but I can’t for the life of me figure out what.

I have a number of very simple projects to install 3rd party agents on a server, and I want to bundle them all up into one project using Deploy a Release step.

  • All six releases have the same lifecycle & channel as each other and as the bundle project.
  • All six releases have the same roles applied. I can’t assign roles on the bundle project, by design I assume.
  • All six releases are set to ‘Deploy every time’.

When I go to deploy my bundled release, there are no deployment targets available.

Each individual project can see deployment targets and deploy releases just fine.

(Reece) #3

Hi Rohin,

Thanks for getting in touch, I appreciate your patience.

In the deployment preview section, we show the machines that each step will execute on.

The Deploy Release step doesn’t execute on machines (as it runs on the Octopus Server) so it doesn’t show the target machines.

Whereas the Deploy Package step does execute on machines, so it will display each of the machines it’s going to run on.

This has been discussed in the following issue found here; I’d recommend having a look here for a breakdown.

A UserVoice suggestion (which is mentioned in the associated ticket) can be found below; I’d recommend leaving your vote and thoughts for this.

I hope this helps!

If you require any further assistance or clarification, please let me know :slight_smile:

Kind Regards,

Reece

(rohin.mcdermott) #4

Thanks. Yep that all makes sense. Sorted now. :+1:

(Reece) #5

Hi Rohin,

Thanks for getting back to me,

Not a problem, if I can be of any assistance moving forward, please let me know :slight_smile:

Have a great day!

Kind Regards,

Reece

(system) closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.