Worker Pool - The account applied to this endpoint is not available globally for the worker

I’m new to the “worker pools” feature in Octopus. I’ve setup a worker pool and am trying to add an SSH worker to the pool.

When I do I get an error:

The account applied to this endpoint is not available globally for the worker.

I understand this relates to the Account I am selecting. But I can’t figure out how to register the Account for the Worker Pool. I don’t see an option to select Worker Pools when creating/editing Accounts.

I can only select Tenants and Environments

I was thinking of having different worker pools for each of my Test, UAT and Production environments. I’m not sure if this is the correct interpretation of pools but it would allow me to control the deployment workers per environment.

How do I register an SSH node for a worker pool?

Any guidance appreciated.

Hi @Chris_Tamlyn
Thanks for reaching out.

To add an SSH node to a worker pool, presuming you have successfully added it as a worker already, go to Infrastructure–>SSH node name–>Settings and there you can select which Worker pool to add it to.

As for scoping different pools for different environments, this is what the pools were designed for. Our docs go through this usage in detail if you want to follow the steps there:

There is quite a lot of good info on that page and also the main worker pool page:

As you noted, Accounts cannot be scoped to Worker Pools, but using other variables (environments, processes and steps etc) you should be able to scope what you need.

Let me know if you need more info on this.

Kind Regards

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.