Word 'Package' as a part of the name of library

I have a problem with two libraries called PackageService.dll and PackageService.XMLSerializers.dll. Both are in my application. When I deploy project via Octopus they are not copied into final folder. I know that they are in nuget package on Octopus server and on Tentacle. I checked it. I think that problem is connected to the word ‘Package’ because I tested different names of these dll. They were copied when I little changed names to e.g. PickageService or _PackageService. Is word ‘Package’ restricted in Octopus as a begin of a file name or it is a bug?

Hi Adrian,

Can you open the nupkg in the NuGet Package Explorer? Are you able to see the DLL’s when opening it with that tool?

Octopus doesn’t have any reserved names for files so this does sound like a bug.

Paul Stovell
Octopus Deploy
W: octopusdeploy.com | T: @octopusdeploy

Hi Paul
I opened package by explorer but I didn’t able to see those DLL’s. I tried to add them by this explorer but after save and reopen they were still absent.

Hi Adrian,

This is the problem; adding them to the ZIP isn’t enough as they need to be added to a manifest file contained in the ZIP. They won’t be extracted by Octopus for the same reason that they won’t appear in the NuGet Package Explorer.

You will need include the files in the directory that is being packaged before the NuGet package is created.

Hope this helps,


Just to inform and close topic. I changed library name from PackageService into PackService and problem was solved. So, I’m quite sure that NuGet don’t like the word Package in the name of libraries.