Windows new line characters in multi-line parameter

I have a parameter which is setup as ‘multi line string’

Its being used to create a new file. The contents of the parameter are dumped into the file. (The community step: “File System - Create File” is being used for this)

The file is created on windows - and the linebreaks seem to not be in the windows format. If I open the file using notepad, the linebreaks are lost and everything appears on one line.

In notepad++ however I still see the linebreaks.

Is there any workaround for this? I’ve tried using \r\n directly in the content - didn’t help. I’ve also tried editing the script on a windows machine - no effect.

I’m using the community step: 'File System - Create File, using utf-8 for the encoding parameter.

Hey @ali.akhtar,

I’m just checking this out for you, and I’ll come back to you later today with my findings.

Thanks

1 Like

Hey @ali.akhtar,

I’ve just tested this, and it all looks good on my end.

What file are you creating?

Are you running the step on a windows machine? If so, could you give me some details on the machine you are deploying to and the tentacle version?

Thanks