"which" command is now required for Linux workers, it seems

Just as an FYI in case others see this.

We recently upgraded Octopus Server and Calamari, and noticed that “kubectl” could no longer be found on the workers.

We noticed this change to Calamari 9 months ago:

i.e., Calamari now uses “which” to locate “kubectl”. For minimal workers (Docker containers), “which” may not be installed.

cc @dgard1981 @Justin_Walsh this could be the root cause on Kubernetes deployment target health checks failing .

1 Like

Thanks for the heads-up on this one, @cjacobsen!

Hopefully, it helps others who are running their deployments on “just enough operating system” workers.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.