When create a new release via octo.exe releasenotefile argument is not working


I’m trying to create a new release in Octopus Deploy using the octo.exe tool in Team City and I’m having the following error:

Unrecognized command arguments: --releasenotefile, ./src/Project/_changelog.txt

This error is most likely occurring while executing octo as part of an automated build process. The following doc is recommended to get some tips on how to troubleshoot this: https://g.octopushq.com/OctoexeTroubleshooting

The command generated is

octo.exe create-release --server http://od.local/ --apikey SECRET --project MyAwesomeProject --enableservicemessages --version 1.1.2-rc.1 --channel MyChannel --deployto Env --progress --packageversion 1.1.2-rc.1 --releasenotefile ./src/Project/_changelog.txt

Hi Ricardo,

Thanks for getting in touch!

Are you using the Octopus plugin within TeamCity or running octo commands directly?
Also, can you confirm what version of octo is being used?


Hi @paul.calvert,

Thanks for getting back on me in such a short notice. I’m using the official plugin in Team City called Octopus Deploy integration with version 6.0.1.

In the Additional command line arguments I’m using

--packageversion %build.number% --releaseNoteFile path/to/file.txt

I also tried the releaseNoteFile argument with multiple combinations

  • releaseNoteFile=“path”
  • “releaseNoteFile=path”
  • releaseNoteFile “path”

OK, I’ve looked at our documentation on this and I noticed that there are two slightly different commands:

--releaseNoteFile, --releaseNotesFile=VALUE
                             [Optional] Path to a file that contains Release
                             Notes for the new release. Supports Markdown

When I tested --releaseNoteFile I received the same error as you, however, --releaseNotesFile did seem to work.
Could you try adding the additional ‘s’ in there and re-run the build?


Hi @paul.calvert,

You’re the best, works perfectly! releaseNotesFile is definitely the way to go.

As curiosity why releaseNoteFile is even there? It’s quite misleading…!

Anyhow, thanks for the support!

Glad to hear it is working, I am querying this internally to determine if the documentation needs updating.


Thanks a mil @paul.calvert!

1 Like

Hi Ricardo,

The reasoning behind this is that we accidentally changed the argument from ReleaseNotesFile to ReleaseNoteFile in octo 7.3.3 (https://github.com/OctopusDeploy/OctopusCLI/issues/70) and then in following versions we allowed either to be used.
I’m assuming that your TeamCity server is using an octo CLI version older than 7.3.3 which is why you saw the error.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.