Waitfordeployment erroring out due to increase in API response time on the server

Hi team, we are currently using --waitfordeployment --deploymenttimeout=02:00:00 as options when triggering a deployment.

Say – “Project 1 initiates deployment of Project 2”

During the deployment, we have noticed that the CPU usage and the response time on the server increases, resulting in Project 1 erroring out:

Octopus Server returned an error: Specified argument was out of the range of valid values.
(Parameter ‘value’)
Error from Octopus Server (HTTP 500 InternalServerError)

Even though the deployment of Project 2 keeps running.

Is there a way we could have a polling setup the “-waitfordeployment” doesn’t fail over like that

Hey @Naman.Kumar,

Thanks for reaching out!

It seems like the best solution for what you would like to achieve could perhaps be done by leveraging a parent/cooperating project?

If you haven’t read it already, we have some excellent documentation covering how you can coordinate multiple projects together; you can check it out here: Coordinating multiple projects - Octopus Deploy.

The idea is that the parent project orchestrates the deployments of other projects based upon settings specified by you.

If you check out the docs I’ve linked above and decide it’s not what you’re looking for, please get back in touch, and I’ll do my best to assist you further.

Kind Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.