--waitForDeploy not actually waiting but timing out?

We some environments that share a single server and have automated the deployments using powershell and the command line tools. Prior to upgrading to Octopus 2.0 we could use the --waitForDeploy switch so that Deploy A would finish before beginning Deploy B, which would finish before beginning Deploy C, and so forth…

However, after upgrading I’ve noticed that after 10 minutes of Deploy A going, I get the message “One or more tasks did not complete before the timeout was reached. We waited 10.1 minutes for the tasks to complete.” even though the task is still running. Deploy B will then begin while Deploy A is still going. This is mainly on a database restore task which can take longer than 10 minutes.

Is there a way to remove this time limit? Or at least change it? Having the deploys run at the same time actually takes longer due to the deploys having to stop and wait for the tentacle to become free. We are currently running

Hi Tabor,

Thanks for getting in touch!

You can set the timeout value using the command line tools with the following setting:

Information about this value can be found here:

Hope that helps!