VSTS Extension - error when creating release


We recently upgraded our server from 3.2.8 to 3.3.4. We are using the ‘Create Octopus Release’ step in Visual Studio Team Services, from your ‘Octopus Deploy Build and Release Tasks’ extension (https://marketplace.visualstudio.com/items?itemName=octopusdeploy.octopus-deploy-build-release-tasks).

This was previously working fine before the server upgrade, although now we are getting an error when this step runs:

2016-04-01T08:33:58.0292363Z Path to Octo.exe = C:\LR\MMS\Services\Mms\TaskAgentProvisioner\Tools\agents\1.97.1\tasks\OctopusCreateRelease\0.4.8\Octo.exe
2016-04-01T08:33:58.1252365Z C:\LR\MMS\Services\Mms\TaskAgentProvisioner\Tools\agents\1.97.1\tasks\OctopusCreateRelease\0.4.8\Octo.exe create-release --project="MyProject" --server=(REMOVED) --apiKey=********  --enableServiceMessages  --releaseNotesFile="C:\a\1\a\release-notes-f85cffc6-32f0-4328-8157-aa6351058277.md" --apiKey=(REMOVED)
2016-04-01T08:33:59.0934918Z Octopus Deploy Command Line Tool, version 3.3.5-vstslog.6+Branch.feature-vstslog.Sha.29928ef936eee077f630df7891e8fdef200a271f
2016-04-01T08:33:59.0944870Z Build environment is TeamFoundationBuild
2016-04-01T08:33:59.0954912Z Handshaking with Octopus server: (REMOVED)
2016-04-01T08:33:59.0954912Z Handshake successful. Octopus version: 3.3.4; API version: 3.0.0
2016-04-01T08:33:59.0963082Z Authenticated as: Scott Gulliver <(REMOVED)> 
2016-04-01T08:33:59.0968916Z Finding project: MyProject
2016-04-01T08:33:59.2619591Z Finding deployment process for project: MyProject
2016-04-01T08:33:59.4841656Z Error from Octopus server (HTTP 200): Unable to process response from server: Error reading string. Unexpected token: StartObject. Path 'Steps[2].Actions[0].Properties.['Octopus.Action.IISWebSite.ApplicationPoolPassword']', line 89, position 67.. Response content: {
2016-04-01T08:33:59.4841656Z   "Id": "deploymentprocess-Projects-181",
2016-04-01T08:33:59.4851649Z   "ProjectId": "Projects-181",
2016-04-01T08:33:59.4861654Z   "Steps": [
2016-04-01T08:33:59.4861654Z     {
2016-04-01T08:33:59.4881653Z Exit code: -7
2016-04-01T08:33:59.5351627Z ##[error]Unexpected exit code -7 returned from tool Octo.exe

I am also able to reproduce this error locally, when using version 3.3.2 of the command line tool (this also worked before the server upgrade). Unfortunately, I haven’t been able to get version 3.3.5 to try locally, as this seems to be the version which the VSTS step is using. If I try the same command from a newer version of the tool (3.3.9), it seems to work fine. Based on this, I’d guess that the VSTS extension likely needs to be updated to make use of a newer version of the octo.exe tool?

Any help would be greatly appreciated.



Hi Scott,

Thanks for getting in touch! With our 3.3 release there was a breaking change that required octo.exe to be updated. We did this for the VSTS build step, however it looks like you are using an older version of our VSTS build step. So I have to assume you are either using an on prem version of VSTS or you complied the step itself and did not use the marketplace version.

You will need to grab the step again and grab the latest version. Details on how can be found here: http://docs.octopus.com/pages/viewpage.action?pageId=3049169
As you have done it once it should just be:

  1. Download the latest version from GitHub
  2. Use tfx-cli to replace the build tasks

Let me know if you have any further questions.

Hi Vanessa,

Thanks for the response.

We are using the microsoft hosted version of VSTS (xxxx.visualstudio.com), and the marketplace version. I’ve removed, and reinstalled the extension, but we still have the same error.

Just as a bit more investigation, I downloaded the extension, and extracted octo.exe from the vsix package - this seems to be version of the octo tool (see attached screenshot), which would probably explain this error. Running this version of the tool locally, calling the create-release command, results in the same error. However, downloading the latest version of octo.exe ( from the octopus downloads page is successful.


We are running into the same problem at the moment. We installed the VSTS build step from the marketplace and as Scott already posted it includes octo.exe v3.3.5 and the bug was fixed in v3.3.7 as far as I can tell.

2016-04-05T12:23:44.7567739Z Octopus Deploy Command Line Tool, version 3.3.5-vstslog.6+Branch.feature-vstslog.Sha.29928ef936eee077f630df7891e8fdef200a271f 
2016-04-05T12:23:44.8661502Z Build environment is TeamFoundationBuild 
2016-04-05T12:23:44.8661502Z Handshaking with Octopus server: *** 
2016-04-05T12:23:44.8817765Z GET ***/api 
2016-04-05T12:23:45.0224036Z Handshake successful. Octopus version: 3.3.1; API version: 3.0.0

Since we are hosting our own build agent I may just replace the octo.exe there for now.



Just an update that we are attempting to get the build step released but apparently there was an MS error when we tried to deploy it and it was during //Build
Hopefully I will have some news for you tomorrow or soon.


Hi Folks,

The VSTS build step in the market place has finally gone through release. Please let me know if that isn’t the case.
We are having mixed experiences with our different environments.