Using 'letsencrypt-prod' as tls secret


(geert) #1

I am deploying containers to a K8S cluster (following the guide at https://docs.microsoft.com/en-us/azure/aks/ingress-tls), and want to use this config:

spec:
  tls:
  - hosts:
    - demo-aks-ingress.eastus.cloudapp.azure.com
    secretName: tls-secret

Unfortunately, OD forces me to select a certificate secret, and I cannot specify the secretName in the configuration of an ingress resource.

This results in the following secret name being passed to AKS:

secretName":"octopus-certificate-#{}"}

How can I make sure this is letsencrypt-prod?


(Shannon Lewis) #3

Hi geert,

Thanks for getting in touch. Unfortunately this is something that Octopus doesn’t currently support. I’ve talked to the team and we agree this is something we should look at adding, we’ve created an issue that you can follow on GitHub.

Sorry I don’t have better news for the moment.

Regards
Shannon


(geert) #4

Thanks for considering this. For now I just apply a custom built ingress config after a deployment.

I could also extract the ingress stuff from the container step and move it into its own step (and disable it), so it’s not blocking us at the moment.


(Shannon Lewis) #5

Thanks, glad to hear you have a workaround for the moment.