User login failed: Missing State Hash Cookie


What happened?

We are trying to create the synthetic check in Datadog which identify the failure and latency in Octopus login. We are using SSO authentication ( Okta ) for the same. But when we are trying to execute the test case, we are getting “Missing State Hash Cookie” error.

Details about private location of Datadog available here :


Same user login is working fine when test on local browser. We tried to run the test on firefox & chrome but same results found.


{“title”:“Bad request”,“message”:“There was a problem with your request.”,“details”:{“ErrorMessage”:“There was a problem with your request.”,“Errors”:[“User login failed: Missing State Hash Cookie. As a security precaution, Octopus ensures the state object returned from the external identity provider matches what it expected. In this case the Cookie containing the SHA256 hash of the state object is missing from the request.”]}}

More Information

We tried to solve the problem by following this doc Troubleshooting authentication problems - Octopus Deploy but still issue persist.

We already using HTTPS in URL.

Good afternoon @gauravg,

Welcome to the Octopus Forums and sorry to hear you are having trouble with your Octopus instance and running checks in external monitoring software.

Are you able to logon to Octopus itself using OKTA? Or are you getting the same errors when trying to logon to Octopus via the Octopus UI Okta button?

We have had some issues in the past with Okta and certain browsers, Firefox and Chrome seem to be the main culprits. I was wondering if you could try running the test using Edge at all? (is this what you meant by ‘Same user login is working fine when test on local browser’)

I know you said you tried following our documentation and you mentioned you use HTTPS but did you check that cookies were enabled on your browsers? Some organisations disabled certain ones via group policies. Did you also check the time on your servers to make sure they all match?

Let me know if using Edge works, the other thing that would be good for troubleshooting here if you are able to is getting a HAR file capture of when you are performing this task as that should show us what calls are being made and erroring out. I have created you a secure link here that you can upload the HAR file to. Let us know when its been uploaded as we aren’t notified.

I look forward to hearing from you,

Kind Regards,


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.