Upgrade Tentacles Missing in 3.2.15

I upgraded my Octopus server to 3.2.15 yesterday and now all my tentacles are out of sync and the update tentacles button is gone from the environments page. Is this by design now?

Hi Matt,

Thanks for reaching out. What version are your Tentacles running? Are you able to deploy to them despite their version is not matching the Octopus Server?



I thought I wanted to upgrade from 3.2.14 to avoid tentacle communication issues as you said, and now that I upgraded to 3.2.15 I have tentacle communication issues!

I cannot physically go an manually update tentacles to version 3.2.15 across all our environments now. Always depended on Octopus server to do that via the Environments page.

Tried to look and reinstall server 3.2.14 but the download link has been removed. Does that mean, the only option I have now is to further downgrade to 3.2.13!?

Please advice ASAP!

Deployments are breaking!!!

I was running both server and tentacle version 3.2.14, prior to this morning. Once I upgraded the server to 3.2.15 this morning I went to the environments pages as usual to upgrade the tentacles and upgrade button at the top of the page was gone. I had to manually run the tentacle installer on each on my tentacle server just to get them to upgrade and get back up and running.


Hi Matthew,

I’m very sorry to hear you had to go through that pain. We tried to get 3.2.14 out of rotation as fast as possible to avoid having this issue spreading to further user’s environments. I’m glad to hear though that you figured the right workaround on your own.

For anyone else running into this issue, please follow this thread -> http://help.octopusdeploy.com/discussions/problems/43799-all-tentacles-show-as-offline-after-upgrade-to-3215