[ Upgrade ] Missing and Extra files

Hello Octopus Team,

I’m facing errors after upgrading from 2021.1.7469 to 2021.3.8275.

2021-11-25 15:21:44.1039 6564 10 WARN - FAIL: Files required to successfully run were not found.
2021-11-25 15:21:44.1039 6564 10 WARN To get your Octopus Server back up and running, please re-run the installer for this version of Octopus Server.
2021-11-25 15:21:44.1039 6564 10 WARN If this issue persists, try disabling your anti-virus and re-installing - we sometimes find overzealous anti-virus software can lock or quarantine necessary files.
2021-11-25 15:21:44.1039 6564 10 WARN If neither of these options works, please contact support@octopus.com with a copy of your Octopus Server log files so we can help you get back up and running.
2021-11-25 15:21:44.1039 6564 10 WARN Missing files detected in Octopus directory:


2021-11-25 15:21:44.2287 6564 10 WARN - FAIL: 1493 extra files detected in the Octopus directory
2021-11-25 15:21:44.2287 6564 10 WARN Extra files under Octopus directory:

Followed by a list of files, I’m joining the server log with all details : OctopusServer_clean.txt.

I’ve tried to repair the installation twice without success, so before Antivirus modifications or total reinstall I’m asking for support :wink:

Kind regards,


Hi @gregory.blanc,

Thanks for reaching out!

Can I ask a few questions, please?

  • Are you running the installer with an admin account?
  • Would you be able to double-check where you’re setting the install path to when you run the installer?

The reason for the second question is you would likely see the errors you’ve experienced if installing Octopus to the Octopus Home folder: (C:\Octopus by default), instead of the Octopus Install Directory (C:\Program Files\Octopus Deploy\Octopus by default).

Let me know on the above or if any of the information helps, please!

If you have any questions then don’t hesitate to get back in touch.

Kind Regards,

Hi @adam.hollow,

The user is local admin of the server and I can’t check the install path making repairs.
But it’s unlikely that this parameter changed just for this upgrade.

I will double check with our SysAdmins about any rights update for this account and then try reinstall this staging server.
But I’d like to have confirmations that this will not happen in our production server :slight_smile:

Kind regards,


Hi @adam.hollow,

I’ve uninstalled Octopus Server and reinstalled it, but still the same messages in the log file.

Is there any bug with the Octopus.2021.3.8275-x64.msi?
I’ve checked the MD5 hash after download.

Kind regards,


Hi @gregory.blanc,

Thanks for getting back in touch, I’m not aware of any issues and no other users have reported any issues using that installer.

I’ll discuss the issues you’re having with the rest of the team and get back in touch with our findings.

In the mean time, can you send me a screenshot of the contents of your Octopus Home folder (C:\Octopus by default) and the Octopus Install folder? (C:\Program Files\Octopus Deploy\Octopus by default).

If there are unexpected files as the installer seems to believe then we should be able to tell from a screenshot.

Kind Regards,

Hi @adam.hollow,

Here the screenshots you asked for :

  • Octopus Home folder (D:\Octopus in our case) :

  • Octopus Server Instance folder :

  • Octopus Server intances folder :

  • Octopus Server intances config file :

“Name”: “octopus-build”,`
“ConfigurationFilePath”: “D:\Octopus\octopus-build\OctopusServer-octopus-build.config”

  • For the install folder (C:\Program Files\Octopus Deploy\Octopus) I attach you a file cause it’s a bit tricky to screenshot a 654 items list : OctopusInstallFolder_itemList.txt

To help you find out a bit more, despite those messages the Octopus server instance seems to run smoothly but I would not have such messages in our Production instance.

Kind regards,

Hi @gregory.blanc,

Thanks for your response and for your patience here.

I think a good step to try would be to first retrieve a copy of your master key, then uninstall Octopus via Add or Remove Programs in Control Panel, then either delete or rename the folder C:\Program Files\Octopus Deploy, then attempt to reinstall Octopus Server.

Let me know if you’re able to give this a try as it will essentially provide Octopus with a fresh installation directory. Your instance configuration will remain intact as well as the Octopus Home folder.

Kind Regards,

Hi @adam.hollow,

I’ve reinstalled but when I start the instance always the same errors in logs about missing and extra files.

There’s another log file error at instance start that I did not noticed before (auto-closing window) :

In text for simpler copy/paste :

Access is denied.
   at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start(String fileName)
   at Octopus.Manager.Server.Shared.Dialogs.RunProcessDialog.LogsHyperlink_Click(Object sender, RoutedEventArgs e) in RunProcessDialog.cs:line 121
   at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
   at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
   at System.Windows.Documents.Hyperlink.OnClick()
   at System.Windows.Documents.Hyperlink.DispatchNavigation(Object sender)
   at System.Windows.Documents.Hyperlink.OnMouseLeftButtonUp(Object sender, MouseButtonEventArgs e)
   at System.Windows.Documents.Hyperlink.OnMouseLeftButtonUp(MouseButtonEventArgs e)
   at System.Windows.RoutedEventArgs.InvokeHandler(Delegate handler, Object target)
   at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
   at System.Windows.UIElement.ReRaiseEventAs(DependencyObject sender, RoutedEventArgs args, RoutedEvent newEvent)
   at System.Windows.RoutedEventArgs.InvokeHandler(Delegate handler, Object target)
   at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
   at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
   at System.Windows.ContentElement.RaiseTrustedEvent(RoutedEventArgs args)
   at System.Windows.Input.InputManager.ProcessStagingArea()
   at System.Windows.Input.InputProviderSite.ReportInput(InputReport inputReport)
   at System.Windows.Interop.HwndMouseInputProvider.ReportInput(IntPtr hwnd, InputMode mode, Int32 timestamp, RawMouseActions actions, Int32 x, Int32 y, Int32 wheel)
   at System.Windows.Interop.HwndMouseInputProvider.FilterMessage(IntPtr hwnd, WindowMessage msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at System.Windows.Interop.HwndSource.InputFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Maybe it could give you a better hint of what’s happening,

Best regards,

Hi Gregory,

I believe the Access Denied error is a known issue within the installer and isn’t actually an issue with the instance itself.

Just to confirm, when you performed the reinstall did you delete the C:\Program Files\Octopus Deploy folder after uninstalling?

It may also be worth checking the database table dbo.OctopusServerInstallationHistory to confirm what the latest version recorded in there is and ensure that matches the one you’re trying to install.


Hello @paul.calvert,

I did not deleted the C:\Program Files\Octopus Deploy folder but only let the uninstall process delete the C:\Program Files\Octopus Deploy\Octopus folder.
Because it contains the subfolder C:\Program Files\Octopus Deploy\Tentacle that is the folder for a Tentacle instance of our Production server on our Staging server to automate refresh of the staging environnement.

I can confirm you that the version recorded in the database table dbo.OctopusServerInstallationHistory is the same as the version I’m trying to install :


Thanks for confirming that.

I believe this may be a bug in the latest version. I seem to have reproduced it, though not entirely sure how. I’m going to work on confirming this.

Even though I’m getting the error in my logs regarding all the missing(and additional) files, my instance is still coming online and functioning normally.

Is this error blocking your instance from running?

No, like I mentionned on a previous message the instance seems to run normaly.

However I can’t install it on Production with this kind of errors in the installer log.

I’ve managed to track down the actual issue here.

The check being performed when the service starts uses the Octopus.Server.manifest file to confirm that all required files are available. In 2021.3.8275 it seems that the original build path for our files is being included in Octopus.Server.manifest causing the service to look in the wrong location for them.

I’ve raised an issue for our engineers to investigate and resolve.

Thanks for your investigations and give me back informations !

Waiting for your engineers to fix this I will install the latest patch of previous minor version.

Kind regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.