Updating a Step Template Using Windows Service Breaks Deployment

We are running 2020.5.3+Branch.tags-2020.5.3.Sha.660191abb3937208749863bc12f6249a62b62bac.

It appears that if you are using a custom path in the Windows Service builtin step in a step template, a runbook or project Process will not run sc config if you update the a custom template’s step, and then update a process or Runbook to use the most recent version of that template.

When you run, it just deploys the files and doesn’t run the service reconfiguration.

If I delete the step and re-add it using the step template, then it sort of works again (is modifying everything except start type (start= sc.exe config parameter).

I am using the Custom Installation Path feature.

Hi @jesse.wolfe,

Thanks for getting in touch!

It sounds like you may be running into a known issue where the settings within a step template can get overwritten to the default values. Importing a step template can overwrite the templates configuration with default settings · Issue #6680 · OctopusDeploy/Issues · GitHub

A fix for this has recently been added, so, upgrading to the latest version may improve this for you.

Regards,
Paul

Hi Paul -

I reviewed the defect. In the description, adding a step from a template causes the issue, and supposedly modifying the step template and then updating it in the consumer fixes the problem.

Once I “refresh” the Runbook to use “the latest”, it just stops modifying the service completely. The default BeforePostDeploy.ps1 scripts appear to be empty (I didn’t inspect, but there are no execution output).

On a lark, I tried updating the step template when NOT using a custom install path. In this case, the deploy ran just fine. It updated the change I made.

So it also seems connected to using a custom install path.

Do you agree this is a bug?

Jesse

When performing the testing I detailed in the other topic, I also made some other changes within the step template and applied these and they did seem to work as expected in 2020.5.8.