Unable to update Project Group

Hey all,

I’m trying to change the description of a Project Group, but I’m unable to do so.

Initially I tried to use the UI, but I saw this error.

The same error is also shown when I use the API.

    "ErrorMessage": "There was a problem with your request.",
    "Errors": [
        "The Id field is required."
    "Details": {
        "Id": "The Id field is required."

Is this a know error with a work around? I’d prefer to not have to go through this elongated process -

  1. Create a temporary group
  2. Move all projects temporary group
  3. Delete the original group
  4. Create a new group with the correct name/description
  5. Move all projects to the new group
  6. Delete the temporary group


Hi @dgard1981,

Thank you for contacting Octopus Support. I’m sorry you are running into this issue with rename your Project Group.

As a potential workaround, you could try renaming the Project Group by using Swagger. You can access Swagger for your instance by navigating to https://YOUR_OCTOPUS_URL/swaggerui.

You’ll need to enter an API key with appropriate permission as shown below:

You’ll then scroll down to ProjectGroups and find the GET /{baseSpaceId}/projectgroups/{id} heading:

With the row expanded, enter the information for the Project Group you wish to rename similar to my example below, then copy the Response Body:

Scroll down to the PUT /{baseSpaceId}/projectgroups/{id} heading. Paste the Response Body JSON you just copied in the body field then change the Name value in the JSON as desired. Fill the SpaceId and ProjectGroupId fields then execute, similar to the example below:

Let me know if that works at your earliest convenience.

Best Regards,

Hi Donny,

Thanks for the reply, but as mentioned in the OP, I’ve already tried using the API and I see the same error (although I see I did originally paste in the request body, not the response body :man_facepalming:).


Hi @dgard1981,

Thank you for getting back to me and clarifying.

I was able to reproduce this issue in an Octopus Cloud test instance. It looks like we do have an issue in for this here.

Unfortunately, there isn’t a great workaround outside of the aforementioned moving Projects to a new Project Group. However, if this isn’t terribly urgent, I can’t yet tell when it will happen though it does look like the next upgrade for your cloud instance will likely include the patch for this issue.

I wish I had a better workaround for you. If you have any additional questions about this or anything else, please don’t hesitate to task.

Best Regards,

Thanks Donny, hopefully the update is rolled out fairly quickly.

And just to confirm - this happens when trying to rename the group OR change the description. In my case, it’s the description I need to change, hence the need to move projects twice.


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.