Unable to see teamCity packages in Octopus deploy

i’m using teamCity; i have NuGet Server enabled; i have a successful build with a .nupkg artifact. I can download the package (artifact) from the artifact tab; I have only one build step, using MSBuild runner, where “run Octopack” is checked.

In Octopus deploy, NuGet Feeds test is failing with this error:

Unhandled error on request: http://localhost:82/api/feeds/feeds-1/packages?packageId=1&partialMatch=true&take=10 : Could not connect to the feed specified at ‘http://localhost:81/httpAuth/app/nuget/v1/FeedService.svc/Packages’. Please verify that the package source (located in the Package Manager Settings) is valid and ensure your network connectivity.

Clicking http://localhost:81/httpAuth/app/nuget/v1/FeedService.svc/Packages) in the browser, displays this:

<?xml version="1.0" encoding="utf-8" standalone="yes" ?>Packageshttp://localhost:81/httpAuth/app/nuget/v1/FeedService.svc/Packages2014-02-01T03:55:37Zhttp://localhost:81/httpAuth/app/nuget/v1/FeedService.svc/Packages(Id='UCSD.BBIS.Parts.Customization',Version='1.0.20')UCSD.BBIS.Parts.CustomizationThe UCSD.BBIS.Parts.Customization deployment......

Any ideas? thanks

got it! - problem resolved.
i missed a configuration step - I didn’t see this in any documentation.

it was the package manager settings outlined here:

steps i took:
1 - vs 2010 - tools - nuGet package manager - package Manager settings - package sources; add the teamcity feed here.
2 - commit solution suo file to source control.
3 - rebuild
4 - remove “Packages” from off the end of the feed URL in Octopus deploy.

I can see the packages now - thank heavens!