Unable to logout

I’ve tried IE, Firefox and Chrome. Whenever I am logged in, I click logout and it does nothing. The page simply reloads and shows the dashboard again…

Hi Gavin,

Are you using Windows authentication?


Yes, it is using Windows Authentication… I guess that’s why I can’t change the password either in my related discussion: http://help.octopusdeploy.com/discussions/problems/7186-change-another-users-password


Hi Gavin,

That’s right, you’ll need to reset passwords through Windows/AD. We really should hide the logout button when running under Windows authentication.


till, cant i logout somehow and login as administrator ?

Hi Gavin,

Your browser sends your credentials to IIS which authenticates you - Octopus plays no part in that authentication. So unfortunately when Windows authentication is used we can’t log you out.

The only way to accomplish this would be to start a new browser session under the account you wish to switch to.


This one is biting me, too. When trying to access Configuration | Storage remotely, I tried using a different account when I was prompted with the Windows authentication screen. Logout didn’t work. Deleting cookies didn’t work.

Eventually, I added the 2nd account to the admin group, went to storage remotely again, and used my original account which fixed everything up. Having the logout feature work would have been helpful

+1. For now, I open the 2nd account using another browser session using Chrome in incognito mode.

It would be nice, if we can have a feature similar to that in Zendesk. i.e., having a separate URL for normal login access / override. Ex:

  1. http://octopus.mycompany.com/access/normal which should take us to a separate login page
  2. use an Administrator account manually created in the Octopus system.

By the way, great tool and I love it.